Bug 85399 - FILEOPEN: hang opening XLSX file
Summary: FILEOPEN: hang opening XLSX file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-24 09:37 UTC by 1d59003e
Modified: 2015-06-19 17:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a spreadsheet with a pricelist (2.26 MB, application/vnd.openxmlformats-officedocument.spreadsheetml)
2014-10-24 09:37 UTC, 1d59003e
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 1d59003e 2014-10-24 09:37:59 UTC
Created attachment 108343 [details]
a spreadsheet with a pricelist

opening this specific file, libreoffice will hang and stop responding (without open the file)
Comment 1 Buovjaga 2014-10-24 13:24:25 UTC
For me it doesn't hang, just takes a while to load. About 1 min on Win 7 64-bit 4.3.2.2 and about 40 secs on dev build Version: 4.4.0.0.alpha1+
Build ID: 0a82645c360158f9cc0fdabe2a52f1ff8f981bed
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-24_06:59:23

Would you mind installing the latest stable, 4.3.2.2, and trying to open again?
Also: how much memory does your computer have? I have 8 GB on this machine.
Comment 2 MM 2014-10-24 13:34:30 UTC
Unconfirmed with v4.3.3.1 under mint 17 x64.
Unconfirmed with v4.3.2.2 under windows 7 x64.

Loads just fine, a bit slow (room for improvement), but everything is there.
Comment 3 1d59003e 2014-10-24 13:37:00 UTC
8 GB too, win 7 x64, i7-4770

after 11 minutes, still task manager report Libreoffice "not responding". CPU is running 13% fixed. 

Currently I cannot downgrade version, however I've this problem from many versions (at least from 4.0) so I'm quite sure that I will have also using the 4.3.2.2.
Comment 4 raal 2014-10-24 13:37:26 UTC
I can open this file with LO 4.3.2, windows 7.
Comment 5 Buovjaga 2014-10-24 13:48:25 UTC
(In reply to 1d59003e from comment #3)
> 
> Currently I cannot downgrade version, however I've this problem from many
> versions (at least from 4.0) so I'm quite sure that I will have also using
> the 4.3.2.2.

Did you mistype "upgrade"? 4.3.2.2 has many fixes in relation to the older version you are using, so we would very much like to hear your result with it. Maybe you can test on some other computer, if you don't want to upgrade yet on your workstation?
So far we have three testers on Win 7 that could not reproduce the hang with 4.3.2.2.
Comment 6 1d59003e 2014-10-24 14:17:07 UTC
Tried on a collegue PC: Win 8.1 x64, LO 4.3.0.4, 16 GB RAM, i7-4770

same problem :(
Comment 7 Buovjaga 2014-10-24 14:20:14 UTC
(In reply to 1d59003e from comment #6)
> Tried on a collegue PC: Win 8.1 x64, LO 4.3.0.4, 16 GB RAM, i7-4770
> 
> same problem :(

I was hoping you would test on 4.3.2.2 and not an older version.
Comment 8 1d59003e 2014-10-24 14:30:20 UTC
sorry. Just installed last 4.3.2.2 buildID edfb5295ba211bd31ad47d0bad0118690f76407d from web site.

still same :(
Comment 9 Buovjaga 2014-10-24 15:19:07 UTC
(In reply to 1d59003e from comment #8)
> sorry. Just installed last 4.3.2.2 buildID
> edfb5295ba211bd31ad47d0bad0118690f76407d from web site.
> 
> still same :(

Ok, in weird cases like this, it is advised to clear your user profile:
https://wiki.documentfoundation.org/User_Profile#Resolving_corruption_in_the_user_profile

On Windows, the profile folder to rename is C:\Users\username\AppData\Roaming\LibreOffice\4\user
Comment 10 tommy27 2014-10-26 08:56:23 UTC
(In reply to 1d59003e from comment #3)
> ... 
> however I've this problem from many versions (at least from 4.0) 
> ...

so I set version field to 4.0 all versions. that field should always indicate the earliest release where you saw a bug.

I can confirm bug under Win7x64 sp1 using LibO 4.3.2.2 and a clean user profile.
LibO hangs with no progress in the loading bar and has to be killed.

however the same file can be opened in just 19 seconds in the same laptop using LibO 4.4.0.0.alpha1+

Build ID: 6ba8b7f5eacac969e4781d63718083a05491b1bc
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-24_02:23:51


here's my configuration (it's a 5 years old laptop):

O/S: Microsoft Windows 7 Professional 64-bit SP1
CPU: Intel Mobile Core 2 Duo @ 2.26GHz	
RAM: 4,00GB Dual-Channel DDR2 @ 399MHz (6-6-6-18)
Motherboard: Inventec 1505 (CPU)

so bottomline is that the bug exists in 4.3.x under some Win7x64 machines but seems fixed in 4.4.x master

so I'm marking this as RESOLVED WORKSFORME.

--> 1d59003e@opayq.com
grab a 4.4.x daily build from here: 
http://dev-builds.libreoffice.org/daily/master/Win-x86@42/

install it (you don't need to uninstall 4.3.2.2 which will still run in parallel) and retest.

feel free to revert status if you still see the bug in 4.4.x
otherwise leave status to RESOLVED and wait for 4.4.0 official release (february '15) and keep your finger crossed hoping that next 4.3.x releases will somehow work (sometimes fixes in master are backported in previous branches too)
Comment 11 tommy27 2015-06-17 08:52:54 UTC
bug reappered in LibO 5.1 alpha (it's still OK in 4.4.3.2)
I opened Bug 92133.

can anyone confirm it on 5.0.x or 5.1.x ?
please  post answers into Bug 92133
Comment 12 tommy27 2015-06-19 17:57:29 UTC
Bug 92133 not reproducible anymore. false allarm.