Bug Hunting Session
Bug 85415 - STYLES: Easy access to create new styles from style drop down
Summary: STYLES: Easy access to create new styles from style drop down
Status: RESOLVED DUPLICATE of bug 74446
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles
  Show dependency treegraph
 
Reported: 2014-10-24 19:04 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-03-16 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shots with ideas etc etc (289.79 KB, image/png)
2014-10-25 15:06 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-10-24 19:04:14 UTC
Easy access to modify existing styles was brought to the style drop down with bug 62081, but no easy means of creating new styles. So i'd like to bring two functions already existing in the styles & formatting dialog to the drop down.

1) New Style - Available when right-clicking style & formatting dialog
2) New Style from Selection - Available in the drop down menu button next to the paint bucket icon and likely labelled 'New Style to Match Selection' so that it fits well with the existing 'Update to Match Selection'.

These two entries would appear above the 'More Styles...' entry and have a separator above and below them.
Comment 1 Cor Nouws 2014-10-24 20:59:52 UTC
Hi Jay,

I don get it completely.
 '... bring two functions .. to the drop down'
<>
 '... would appear above the 'More Styles...' entry and have a separator above and below them."
??
Comment 2 Yousuf Philips (jay) (retired) 2014-10-25 01:29:45 UTC
The styles drop down would look like this.

Clear Formatting
- separator -
[List of Styles]
- separator -
New Style
New Style from Selection
- separator -
More Styles...
Comment 3 Cor Nouws 2014-10-25 09:46:41 UTC
Hi Jay,

Ah, I thought you meant the new drop down at the right side of a styles name.

Now, if you choose new slide from the context menu in the window Styles and Formatting, the newly created style will be inheriting from the style where you choose New.

When there is a choice 'New Style' unrelated to an existing style, that is going to work different?
Comment 4 Yousuf Philips (jay) (retired) 2014-10-25 11:43:50 UTC
Hi Cor,

It would inherit from whatever style that is presently set. Thats the way it happens in the styles and formatting dialog.
Comment 5 Cor Nouws 2014-10-25 15:06:47 UTC
Created attachment 108401 [details]
screen shots with ideas etc etc

Hi Jay,

The New on that position (see "? A" in the attachment) is a bit confusing wrt inheriting.  I think "? B" would be better.

For reference: down left in the image the Styles and formatting window with the same features.
Comment 6 Yousuf Philips (jay) (retired) 2014-10-25 20:00:01 UTC
Hi Cor,

Thanks for the image illustration of the mechanism. I think its worth adding both, as it will satisfy both needs. :D
Comment 7 Cor Nouws 2014-10-27 19:23:25 UTC
Hi Jay,

(In reply to Jay Philips from comment #6)

> Thanks for the image illustration of the mechanism. I think its worth adding
> both, as it will satisfy both needs. :D

I'm afraid it leads to confusion since for A there is no visual link with the  style that will be the basis for the action.
Even if this New would be added in the Style dropdown, still not all functions available in window F11 would be available. So IMHO either only version B, or none at all in the Style dropdown
Comment 8 Cor Nouws 2014-10-27 19:24:15 UTC
confusion and doubling of the entry in the same 'window' hmm...
Comment 9 Yousuf Philips (jay) (retired) 2014-10-28 08:49:21 UTC
Hi Cor,

(In reply to Cor Nouws from comment #7)
> Hi Jay,
> 
> I'm afraid it leads to confusion since for A there is no visual link with
> the  style that will be the basis for the action.

Well i guess the easiest solution is that A is for creating a new style always based on Default. I'm assuming most users not heavily into style will choose this option over opening any of the submenus.

> Even if this New would be added in the Style dropdown, still not all
> functions available in window F11 would be available. So IMHO either only
> version B, or none at all in the Style dropdown

Well we are not trying to duplicate all the functions available in the F11 window, just the most basic ones suitable for the drop down, which a user shouldnt have to go into the F11 window to access.
Comment 10 Cor Nouws 2014-10-28 09:19:38 UTC
Hi Jay,

(In reply to Jay Philips from comment #9)
> (In reply to Cor Nouws from comment #7)
> > I'm afraid it leads to confusion since for A there is no visual link with
> > the  style that will be the basis for the action.
> 
> Well i guess the easiest solution is that A is for creating a new style
> always based on Default. I'm assuming most users not heavily into style will
> choose this option over opening any of the submenus.

I'm not happy at all with such a change that would add a behaviour that is not supported by the visual situation and that is different from the behaviour as is in the window Styles and Formatting.

> > Even if this New would be added in the Style dropdown, still not all
> > functions available in window F11 would be available. So IMHO either only
> > version B, or none at all in the Style dropdown
> 
> Well we are not trying to duplicate all the functions available in the F11

I know.

> window, just the most basic ones suitable for the drop down, which a user
> shouldnt have to go into the F11 window to access.

If the need to bring New to the dropdown is strong enough then definitely in position B.
Comment 11 Yousuf Philips (jay) (retired) 2014-10-28 17:17:49 UTC
Hi Cor,

(In reply to Cor Nouws from comment #10)
> Hi Jay,
> 
> I'm not happy at all with such a change that would add a behaviour that is
> not supported by the visual situation and that is different from the
> behaviour as is in the window Styles and Formatting.

The Styles and Formatting window is a different control to the styles drop down menu, so ultimately their behaviour will be different. The question is, "Should a user be able to create a new style without having to first select a style that it should be based on?" I say yes and you say no, but this behaviour is available in the F11 window. Just right click in the empty white space under the last style, and click 'New' and it will be based on 'Default Style'.
Comment 12 Cor Nouws 2014-10-28 20:54:14 UTC
Hi Jay,

Do I understand it well that you change idea/argumentation in comment#4 and comment#6 and comment#9 (while in comment#0 it's unclear, at least to me) ? 

If you want to have New style in the style dropdown: fine. But then pls to the new dropdown per style, which is a great addition to the tooling. Let's use that. And not add confusing by introducing a new not indicated way it works.
I guess that technically not more difficult then adding it at the bottom of the main dropdown? (In any case there must always be an indication of the parent style).
Comment 13 Yousuf Philips (jay) (retired) 2014-10-28 21:14:25 UTC
(In reply to Cor Nouws from comment #12)
> Hi Jay,

Hi Cor,

> Do I understand it well that you change idea/argumentation in comment#4 and
> comment#6 and comment#9 (while in comment#0 it's unclear, at least to me) ? 

Yes i was confused in comment 4 and after i saw your screenshot, comment 9 is where i'm currently at now about adding both new in the drop down and submenu, which i guess i should have explained at the time of comment 6.

> If you want to have New style in the style dropdown: fine. But then pls to
> the new dropdown per style, which is a great addition to the tooling. Let's
> use that. And not add confusing by introducing a new not indicated way it
> works.
> I guess that technically not more difficult then adding it at the bottom of
> the main dropdown? (In any case there must always be an indication of the
> parent style).

Well i guess this is where we are disagreeing. I dont think that its important to identify the parent style when creating a new style from the main style drop down.
Comment 14 Cor Nouws 2014-11-03 19:12:30 UTC
(In reply to Jay Philips from comment #13)
> (In reply to Cor Nouws from comment #12)

> Well i guess this is where we are disagreeing. I dont think that its
> important to identify the parent style when creating a new style from the
> main style drop down.

Quite obvious yes :)
As written, it's confusing introducing an additional way of creating a style that does not have an indication of the way it works.
When hoovering the list of styles, one sees the drop down per style so one will definitely not miss the New in the submenu.
Also it makes clear to users that there is some dependency.
Furthermore that gives users the full power of new styles inheriting from XYZ, without opening the Stylist.
Comment 15 Yousuf Philips (jay) (retired) 2014-11-03 20:54:29 UTC
(In reply to Cor Nouws from comment #14)
> Quite obvious yes :)
> As written, it's confusing introducing an additional way of creating a style
> that does not have an indication of the way it works.

I see that it works quite straight forward. It gives a user a blank style to being creating the style they wish to create.

> When hoovering the list of styles, one sees the drop down per style so one
> will definitely not miss the New in the submenu.

A user will miss the New in the submenu if they never open the submenu.

> Also it makes clear to users that there is some dependency.

You can set the dependencies within the dialog.

> Furthermore that gives users the full power of new styles inheriting from
> XYZ, without opening the Stylist.

Which is why i said that we do both A and B, so that it fulfills both needs.

I see that we both added this topic to the design team agenda, so let see what they say on wednesday. :D
Comment 16 Cor Nouws 2014-11-03 21:02:14 UTC
(In reply to Jay Philips from comment #15)
> (In reply to Cor Nouws from comment #14)
> > Quite obvious yes :)
> > As written, it's confusing introducing an additional way of creating a style
> > that does not have an indication of the way it works.
> 
> I see that it works quite straight forward. It gives a user a blank style to
> being creating the style they wish to create.

Lacking the information that there is inheritance.

> > When hoovering the list of styles, one sees the drop down per style so one
> > will definitely not miss the New in the submenu.
> 
> A user will miss the New in the submenu if they never open the submenu.

They will miss all if they do not open the style drop down in the first way.
But once that one is opened, only a blind horse will miss the extra drop down :)

> > Also it makes clear to users that there is some dependency.
> 
> You can set the dependencies within the dialog.

Yes, but in my training-experience there is considerable low tendency to look at the details at that page - people jump to font.

> > Furthermore that gives users the full power of new styles inheriting from
> > XYZ, without opening the Stylist.
> 
> Which is why i said that we do both A and B, so that it fulfills both needs.

As a (long distance) second best.. ;)

> I see that we both added this topic to the design team agenda, so let see
> what they say on wednesday. :D

Hope the team enjoys the meeting :)
Comment 17 Yousuf Philips (jay) (retired) 2014-11-03 21:56:40 UTC
(In reply to Cor Nouws from comment #16)
> > I see that it works quite straight forward. It gives a user a blank style to
> > being creating the style they wish to create.
> 
> Lacking the information that there is inheritance.

Well many users dont know about inheritance, but they know they for example want to create a new style which has blue text at 20pt and is centered. So for them to start at a clean slate is something they would understand.

> > A user will miss the New in the submenu if they never open the submenu.
> 
> They will miss all if they do not open the style drop down in the first way.
> But once that one is opened, only a blind horse will miss the extra drop
> down :)

Yes most definitely we have many non-style users, but many will likely not miss the drop down popping up next to each style name, but that wont necessarily make them choose to open it. ;D

> > You can set the dependencies within the dialog.
> 
> Yes, but in my training-experience there is considerable low tendency to
> look at the details at that page - people jump to font.

Which is why we have B for such users. :D

> > Which is why i said that we do both A and B, so that it fulfills both needs.
> 
> As a (long distance) second best.. ;)

Well its primarily to cater to non-advanced style users (me included). :D

> > I see that we both added this topic to the design team agenda, so let see
> > what they say on wednesday. :D
> 
> Hope the team enjoys the meeting :)

Hopefully it will be a good turn out. Sorry to hear that you cant make it. :(
Comment 18 Cor Nouws 2014-11-04 08:52:27 UTC
" it would be good to streamline them to using the sub menus for all style handling stuff, and not enlarge the clutter in the main drop down."
(free to 85820 ;) )
Comment 19 Yousuf Philips (jay) (retired) 2014-11-14 03:25:45 UTC
Setting this to NEW. The design team discussed it on the Nov 5th and said it was useful to have it in both places.
Comment 20 Marcel Partap 2019-03-12 10:41:41 UTC
for me in Debian's libreoffice writer 6.1.5-1, when I select formatted text and click on the ... uh 😳 .. totally missed this:
Even though the icon's caption says "New Style from Selection", the actions are named only "New Style" & "Update Style".. if you do not read the caption, you will not come to the conclusion these are with regard to the current selection. Mhh.

Independent from that, the "New Style from Selection" and another "Update Style from Selection" should be listed in the "Styles" subsection of the context menu of selected formatted text.
Comment 21 Cor Nouws 2019-03-16 08:47:32 UTC
I think this is resolved in bug 74446

If somthing really misses, please file a clear new bug, referring to this/the other one?
thanks! Cor

*** This bug has been marked as a duplicate of bug 74446 ***