Bug 85416 - COLOR PICKER: annoying flickering when picker drop-down is opened
Summary: COLOR PICKER: annoying flickering when picker drop-down is opened
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2014-10-24 19:13 UTC by tommy27
Modified: 2014-10-31 21:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
SWF screencast (96.51 KB, application/x-shockwave-flash)
2014-10-26 08:07 UTC, tommy27
Details
video of the flickering (126.70 KB, video/mp4)
2014-10-27 17:03 UTC, Maxim Monastirsky
Details
screenshot on different platforms (76.38 KB, image/png)
2014-10-29 08:42 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2014-10-24 19:13:59 UTC
tested under Win7x64 using LibO 4.4.0.0.alpha1+
Build ID: 6ba8b7f5eacac969e4781d63718083a05491b1bc
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-24_02:23:51

when you open Writer and click on any of the color pickers buttons either on the toolbar or in the sidebar, the picker window blinks when opening causing an annoying visual glitch
Comment 1 tommy27 2014-10-26 08:07:21 UTC
Created attachment 108431 [details]
SWF screencast
Comment 2 Maxim Monastirsky 2014-10-26 09:12:53 UTC
I guess it's related to the change made in Bug 84676, so that the visible flag is set before the window placement.
Comment 3 Yousuf Philips (jay) (retired) 2014-10-26 10:24:43 UTC
I believe the visual glitch is caused by the palette list getting larger, the scrollbar showing up, the recent list label moving and the recent list shrinking. I'm assuming when all the bugs already reported about these things are fixed, the glitch will likely only be visible in the palette list. :)
Comment 4 Adolfo Jayme 2014-10-27 14:08:57 UTC
(In reply to Maxim Monastirsky from comment #2)
> I guess it's related to the change made in Bug 84676, so that the visible
> flag is set before the window placement.

Hm, the flickering also happened before that change, IIRC.
Comment 5 Maxim Monastirsky 2014-10-27 17:03:56 UTC
Created attachment 108523 [details]
video of the flickering

Now I realize that probably we're not talking about the same thing. If you'll look at 2 second of the attached video, you'll see the color matrix appearing at the left side, out of the place where the final window is shown. You can see the same effect in Tommy's screencast in the right bottom corner. This can be seen on slow machines. I didn't see it before.
Comment 6 Maxim Monastirsky 2014-10-28 21:44:57 UTC
Should be much less flickering since http://cgit.freedesktop.org/libreoffice/core/commit/?id=3efc3cc5b0b4b6151e928c2348c7dc6f74181db5.
Comment 7 Yousuf Philips (jay) (retired) 2014-10-29 07:30:04 UTC
Flicker is gone now, but the scrollbar went missing after being fixed (bug 84574).
Comment 8 Maxim Monastirsky 2014-10-29 08:42:49 UTC
Created attachment 108611 [details]
screenshot on different platforms

(In reply to Jay Philips from comment #7)
> but the scrollbar went missing after being fixed (bug 84574).
Hmm, It seems to depend on the platform/theme. As you can see from the attached screenshot, it's OK on most platforms. Not sure what goes wrong sometimes.

BTW I searched for the commit the fixed the scrollbar, but couldn't find one (at least that did it intentionally). Any clue?
Comment 9 Yousuf Philips (jay) (retired) 2014-10-29 10:38:46 UTC
(In reply to Maxim Monastirsky from comment #8)
> BTW I searched for the commit the fixed the scrollbar, but couldn't find one
> (at least that did it intentionally). Any clue?

Yes its a tricky thing that shows up some places and not other places. Its not showing for me on Linux Mint 13 Mate [Clearlooks] or Windows 7 [Basic]. On Windows 7, the scrollbar does appear (though slightly cut) in Classic and it shows fine in Aero. I believe Matthew Francis (mjayfrancis) made some modification to the code and thats what fixed it.
Comment 10 tommy27 2014-10-31 21:43:31 UTC
(In reply to Maxim Monastirsky from comment #6)
> Should be much less flickering since
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=3efc3cc5b0b4b6151e928c2348c7dc6f74181db5.

yes, no more flickering with 4.4.0.0.alpha1+
Build ID: 8dbe4f2aebff1bd763e4f44c8f9e2a367316da4b
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-31_14:27:30

VERIFIED FIXED