Download it now!
Bug 85437 - FILEOPEN: wrap set incorrectly to wrap through for frames in DOC file
Summary: FILEOPEN: wrap set incorrectly to wrap through for frames in DOC file
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Frames
  Show dependency treegraph
 
Reported: 2014-10-25 11:57 UTC by Buovjaga
Modified: 2020-04-20 12:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2014-10-25 11:57:38 UTC
DOC file: attachment 108383 [details]
First reported bug related to this file: bug 85430
PDF export using 4.4.0.0 alpha1 from Oct 24: attachment 108384 [details]
PDF export using Word 2010: attachment 108385 [details]

Problems:  Frames on pages 3, 4, 7, 23, 26, 27, 51, 52 and 53 have incorrectly "Wrap through" and they don't have a gradient. Frames on pages 32, 33, 34, 35, 36, 37, 38, 39, 40, 41 and 42 have incorrectly "Wrap through".
Frames on pages 11, 12 are in the wrong position, not hiding the Chinese text.
Comment 1 Buovjaga 2014-10-25 12:03:50 UTC
Quick addition: on page 5, Figure B has a frame between the houses with the text "Wind" that should not be on top of the arrow.
Comment 2 A (Andy) 2014-10-25 12:45:13 UTC
Reproducible already with LO 4.3.2.2 (Win 8.1)
Comment 3 Cor Nouws 2014-10-25 16:24:40 UTC
Hi Beluga,

Would it be possible for you to split this in one issue for each problem?
You may also want to look for possible existing issues that say the same?

thanks,
Cor
Comment 4 Buovjaga 2014-10-26 11:30:39 UTC
Ok let's keep this one for the wrap problem.
Gradient problems are in bug 85480
Position problems are in bug 85481

I searched for dupes, but couldn't find any. Keywords used: frame wrap, frame gradient, frame position.
Comment 5 A (Andy) 2014-10-26 11:51:16 UTC
Wrap problem: Reproducible with LO 4.3.2.2 (Win 8.1)
Comment 6 QA Administrators 2015-12-20 16:12:37 UTC Comment hidden (obsolete)
Comment 7 A (Andy) 2015-12-26 22:28:18 UTC
Still reproducible with LO 5.1.0.1 (Win 8.1) for page 3, 32, 32-42, 51-53
Comment 8 Ari Latvala 2016-03-14 20:46:52 UTC
Problem is still reproducible on the latest 5.1.1.3 version for Windows 7 SP1 64-bit.
Comment 9 Buovjaga 2017-11-03 17:30:35 UTC
Still confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: 64024d7c18bd114eb9958cf80eea9129e09923bd
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 3rd 2017
Comment 10 QA Administrators 2018-11-04 03:56:57 UTC Comment hidden (obsolete)
Comment 11 Ari Latvala 2018-11-04 08:30:16 UTC
Problem still exist on the latest release.

Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 12 Buovjaga 2019-08-09 09:10:45 UTC
Still confirmed

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ed882d693f37779e3a09641e7cd43b7a925d2312
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-25_00:58:18
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 13 Justin L 2020-04-20 10:08:49 UTC
In Word 2003, these are marked as "In front of text" which is equivalent to wrap-through. So I would call this one NOTABUG.

The reason that the text is disappearing underneath the frame is because it is not using fixed spacing 22 properly. (It looks like single spacing instead of 1.5ish spacing.)  But that is the report of another bug for this document already.
Comment 14 Buovjaga 2020-04-20 12:04:57 UTC
Thanks, I will close.