Bug Hunting Session
Bug 85453 - ClearType Font Rendering Looks Terrible
Summary: ClearType Font Rendering Looks Terrible
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 91946
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-25 19:23 UTC by BrendaEM
Modified: 2015-06-10 23:56 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Cropped Screenshot (30.92 KB, image/png)
2014-10-25 19:23 UTC, BrendaEM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BrendaEM 2014-10-25 19:23:07 UTC
Created attachment 108414 [details]
Cropped Screenshot

This may be limited to the windows version, but...

The font rendering looks terrible. In no way can I see any anti-aliasing on the fonts.

It might be a 3K thing, but the text looks bad.
Comment 1 A (Andy) 2014-10-25 20:50:06 UTC
Reproducible with LO 4.3.2.2 (Win 8.1):
With the font Liberation Serif and then zooming in it looks also for me quite pixelated.
Comment 2 BrendaEM 2014-10-25 21:39:14 UTC
Sorry, the system doesn't understand that png's are graphics, is downloadable, viewable and zoomable.

Because the issue involves anti-aliasing issues, I wanted a pixel-accurate format.
Comment 3 Adolfo Jayme 2014-10-26 00:54:11 UTC
I fixed the attachment’s MIME type, that’s why it wasn’t displaying properly on browser.

Your attachment actually shows ClearType antialiasing, which is not the same as “no antialiasing”. I agree it,’s ugly and looks choppy, but that’s how Windows’ GDI+ library renders it.

We could eventually switch to the DirectWrite, but that would mean dropping XP support.
Comment 4 BrendaEM 2014-10-26 16:00:55 UTC
So what you are saying is, this might not be fixed for years?!

Thank you for fixing the mime-type,
Brenda
Comment 5 BrendaEM 2014-10-26 16:04:35 UTC
Respectfully, I am asking your a second opinion further up on the decision chain.
Comment 6 Adolfo Jayme 2014-10-27 13:10:34 UTC
Brenda,

ClearType is not developed by us. Its quirkinesses can only be fixed by Microsoft.

You can workaround it: either switch to Standard font smoothing or install a program called gdipp.
Comment 7 BrendaEM 2014-10-29 19:18:47 UTC
Please correctly, if I am wrong, but there is no "standard font smoothing" in windows.

This is the only windows application, I have this problem with.
Comment 8 BrendaEM 2014-10-29 19:25:14 UTC
I am asking for a look at by someone higher on the chain.

How could LibreOffice be a modern office application without font smoothing?
Comment 9 BrendaEM 2014-10-29 19:28:32 UTC
gdipp has not had a release in over 4 years, making it's security and current compatibility questionable. It is fine to offer a solution, but that solution should work, should it not.

Commentary: this is the kind of situation where open source for all its good intentions sometimes fails. Please don't let that happen here.
Comment 10 Adolfo Jayme 2014-11-01 18:06:36 UTC
> Please correctly, if I am wrong, but there is no "standard font smoothing"
> in windows.

Under XP, there are three options: “None”, “Standard” and “ClearType”.
https://www.winhelp.us/change-font-smoothing-in-windows.html

> gdipp has not had a release in over 4 years, making it's security and
> current compatibility questionable. It is fine to offer a solution, but that
> solution should work, should it not.

Well, it works, doesn’t it?

> Commentary: this is the kind of situation where open source for all its good
> intentions sometimes fails. Please don't let that happen here.

I’ve already told you what the solution would be under Windows: using DirectWrite. That is what Google Chrome developers did after receiving this kind of bug reports repeteadly. Unfortunately, DirectWrite is not available under Windows XP (it’s present in Vista SP2 with Platform Update and above).
Personally I look forward to this, but unless TDF decides to drop XP support, it won’t happen for a while. Please contact the ESC in the development list (libreoffice at lists.freedesktop.org) and let them know your concerns.

Another thing that I had forgotten to mention is that font hinting plays a big role in Windows’ rendering as well. Unfortunately, the Liberation fonts have hinting issues, but that’s NOTOURBUG as well (report that to Red Hat’s Bugzilla).

Believe me, this is one of the reasons why I prefer to use Linux over Windows. ;-)
Comment 11 BrendaEM 2014-11-01 20:30:25 UTC
I am using Windows 7, not XP. There is no such option. Respectfully, your solution is a non-solution. Does not work for me.

The fonts in question are not Liberation.

Windows XP is no longer supported. It's time to move on.