Bug 85521 - Colors of the document are not shown in the color drop-down menu
Summary: Colors of the document are not shown in the color drop-down menu
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget Document-Colors-Palette
  Show dependency treegraph
 
Reported: 2014-10-27 15:25 UTC by sophie
Modified: 2017-04-24 09:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing only font colors but no highlight colors (39.03 KB, image/png)
2017-03-15 12:33 UTC, Thomas Lendo
Details
Test file to above screenshot (9.22 KB, application/vnd.oasis.opendocument.text)
2017-03-15 12:33 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sophie 2014-10-27 15:25:07 UTC
Hi, the new color picker has an option in the palette drop down list 'Document colors'. From what I understand it should collect the colors applied to the document (Font or Highlighting). But it remains empty whatever color I apply. 
I'm using Version: 4.4.0.0.alpha1+
Build ID: 7ef698355ad59c6fa263daa4ded124cf512e8926
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-10-27_09:37:25
To reproduce:
- add some text to writer document
- select a color in the Font color picker and apply it
- do the same for Highlighting
- save the document
- click on Font color icon and select Document colors
==> the list is empty.
Sophie
Comment 1 V Stuart Foote 2014-10-27 21:20:00 UTC
Confirming on Windows 7 sp1, 64-bit en-US with
Version: 4.4.0.0.alpha1+
Build ID: fa58d91094895a530648630fa64b8724ea1e4305
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-26_09:30:18

Color selections picked from the custom color picker show a swatch in the recent area. But nothing is being recorded into the "Document colors" palette--either from opening the document or after making color changes to font or highlighting (and would guess with the area fill when that is converted).

Also, when moving away from the color tools, and then returning--the Recent color swatches have been cleared.  Since they're not yet on the "Document colors" details of any custom color picked is lost.
Comment 2 Adolfo Jayme 2014-12-09 02:28:45 UTC
(In reply to sophie from comment #0)
> Hi, the new color picker has an option in the palette drop down list
> 'Document colors'. From what I understand it should collect the colors
> applied to the document (Font or Highlighting). But it remains empty
> whatever color I apply. 

What I understood was that this list of colors wasn’t a collection of colors you’ve applied (that’s the purpose of “Recent”), but “Document colors” is actually meant to display the colors in a document’s theme (if you create a doc in recent versions of Word, it will have a color theme.) Of course, we still don’t support creating documents with color themes. See also http://blogs.igalia.com/jaragunde/2014/05/28/tales-of-libreoffice-interoperability-font-and-paragraph-colors/
Comment 3 wanchai 2015-02-02 03:56:08 UTC
See also Bug 67995, maybe the two should be merged.
Comment 4 Robinson Tryon (qubit) 2015-02-02 06:28:02 UTC
(In reply to sophie from comment #0)
> Hi, the new color picker has an option in the palette drop down list
> 'Document colors'. From what I understand it should collect the colors
> applied to the document (Font or Highlighting). But it remains empty
> whatever color I apply. 

If the drop-down list is supposed to contain the colors applied to the document (non-color-theme included), then this is a technical bug.

(In reply to Adolfo Jayme from comment #2)
> What I understood was that this list of colors wasn’t a collection of colors
> you’ve applied...but the colors in a document’s theme (if you create a
> doc in recent versions of Word, it will have a color theme.) Of course, we
> still don’t support creating documents with color themes.

If the list of colors is just what's present in a document's theme, then this is a Documentation/UX bug, as the label 'Document colors' is apparently unclear.

Either way,
Status -> NEW

(In reply to wanchai from comment #3)
> See also Bug 67995, maybe the two should be merged.

67995 mentions various improvements that are not mentioned here, including saving the palette alongside the document. I think that these bugs are related, but not equivalent enough to be considered duplicates.
Comment 5 Heiko Tietze 2017-02-18 10:20:35 UTC
The Document colors palette works now like a charm.
Comment 6 Thomas Lendo 2017-03-15 12:33:14 UTC
Created attachment 131901 [details]
Screenshot showing only font colors but no highlight colors

Heiko, is this feature only to list font colors? In my test with LibO 5.3.0.3 there are only font colors listed - but no highlight colors. See the attached screenshot and the test file.
Comment 7 Thomas Lendo 2017-03-15 12:33:49 UTC
Created attachment 131902 [details]
Test file to above screenshot
Comment 8 Heiko Tietze 2017-03-15 14:53:01 UTC
(In reply to Thomas Lendo from comment #6)
> Created attachment 131901 [details]
> Screenshot showing only font colors but no highlight colors
> 
> Heiko, is this feature only to list font colors? In my test with LibO
> 5.3.0.3 there are only font colors listed - but no highlight colors. See the
> attached screenshot and the test file.

This issue with document colors is handled in bug 106187 and bug 106188. The meta ticket for is bug 85184 for issues with color picker toolbar and sidebar drop-down widget plus bug 87064 for the color picker as well as bug 104118 in respect to color palettes (not easy to separate both).