Bug Hunting Session
Bug 85711 - Wrong equation for exponential trend line
Summary: Wrong equation for exponential trend line
Status: RESOLVED DUPLICATE of bug 85659
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-31 18:06 UTC by Regina Henschel
Modified: 2014-11-02 23:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Chart has wrong equation (32.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-10-31 18:06 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2014-10-31 18:06:23 UTC
Created attachment 108739 [details]
Chart has wrong equation

Open the attached document and look at the equation in the chart. It has string "true" where the string " + " should be. The inserted picture below the chart shows, how the equation should look like.
Comment 1 A (Andy) 2014-10-31 20:33:43 UTC
How do you insert this equation?

I have also another buggy behaviour.  The image is not shown when I open the file.  It will only be shown after I make double click on it.  Can anybody confirm this too?

(tested with LO 4.3.3.2, Win 8.1)
Comment 2 Julien Nabet 2014-10-31 21:24:31 UTC
On pc Debian x86-64 with 4.3.3 LO Debian package, I don't reproduce this but I do reproduce this on Win7 with LO 4.3.3.

So Windows only bug indeed.
Comment 3 Julien Nabet 2014-10-31 21:25:02 UTC
A (Andy): I confirm this too.
Comment 4 Regina Henschel 2014-10-31 22:11:42 UTC
(In reply to A (Andy) from comment #1)
> How do you insert this equation?

Bring the chart in edit mode. Click on the data series. Select item "Format Trendline" in context menu, or item "Insert Trendline" in case of a new trendline. Find the checkbox "Show Equation" in the lower part of the dialog.

> I have also another buggy behaviour.  The image is not shown when I open the
> file.  It will only be shown after I make double click on it.  Can anybody
> confirm this too?

See that too with Version: 4.4.0.0.alpha0+
Build ID: 86a3fe47a66950e26d23d7d7f2680fa7d4fb0839
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-05_02:45:20

With Version 4.2.5 the picture is shown immediately.
Comment 5 A (Andy) 2014-10-31 22:37:23 UTC
@Regina and Julien: Thanks for your fast reply and confirmation of the image bug.

@Regina: Thank you also very much for your explanation.  Now I have learned even more about CALC.  Thanks a lot.

And now I can also reproduce it with LO 4.3.3.2, Win 8.1.
Comment 6 Regina Henschel 2014-11-02 23:32:59 UTC

*** This bug has been marked as a duplicate of bug 85659 ***