Bug 85773 - Auto-filter uses wrong, extended range for filtering
Summary: Auto-filter uses wrong, extended range for filtering
Status: RESOLVED DUPLICATE of bug 35923
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures AutoFilter
  Show dependency treegraph
 
Reported: 2014-11-02 19:58 UTC by Teraslilja
Modified: 2021-06-19 13:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Auto-filter feature (18.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-02 19:58 UTC, Teraslilja
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Teraslilja 2014-11-02 19:58:06 UTC
Created attachment 108809 [details]
Auto-filter feature

The documentation (F1) for auto-filter says: "Automatically filters the selected cell range, and creates one-row list boxes with which you can choose the items that you want to display."

How ever, for filtering is used a range that is extended from the given range by rows, until there is an empty cell at bottom.

The version of calc is 4.3.3.2 (not included in version list).

Expected behaviour: as documented.

In attachment, a label and cells 1-9 are selected and auto-filter is created so that the first row is used as label. When filtered items are listed, there are listed also "Bottom1" - "Bottom3" (wrong), but not "Bottom 5" (ok).
Comment 1 Urmas 2014-11-03 02:20:37 UTC
Consistent with Excel behavior, BTW
Comment 2 Teraslilja 2014-11-03 13:56:40 UTC
I would expect such behaviour, when I have selected only the label row, and range is extended columnwise until empty cell.
Comment 3 raal 2014-11-16 19:51:35 UTC
I think this is not a bug. The range is auto resizing, for example write some text into empty cell (Bottom4, cell P20). This text is automaticaly included into range and range is resized.
Comment 4 Joel Madero 2014-11-20 05:17:14 UTC
Ubuntu 14.10 x64
LibreOffice 4.3.2.2 release

Reproducible Steps:

1. Download document;
2. Click P7
3. Data -> Filter -> Autofilter (uncheck it)

Observed: Autofilter goes away (good)

4. Highlight cells P7-P16
5. Data -> Filter -> Autofilter (check it)
6. Click on down arrow on P7 to get the list to appear


Observed: You see values that were not highlighted (values in P17-P19)

Expected: You only see what was highlighted when you applied the auto filter (thus to comport with documentation)


Marking as:
New
Minor - can slow down professional quality work but won't prevent it
Low - I don't see this having a huge impact or anything so not worth raising from default.


Going to check to see if it's a regression right now, if it is I'll bibisect it. Thanks!
Comment 5 Joel Madero 2014-11-20 05:31:19 UTC
Apparently it's always worked this way - updating version as version is the oldest version that we can confirm the issue on. At least PreBibisect.
Comment 6 QA Administrators 2015-12-20 16:15:25 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-14 15:45:15 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2017-09-29 08:51:24 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2019-02-03 20:27:49 UTC Comment hidden (obsolete)
Comment 10 stragu 2021-06-16 13:25:35 UTC
Reproduced in:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: de7356c2e0cb099fac396808b5a86a0393b48e5f
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-14_22:38:17
Calc: threaded

In my opinion, this is more than "low - minor". Imagine this:
- select range, setup autofilter
- use a filter to hide rows, expecting it to only affect selected range (understandably!)
- rows below the range might end up being hidden, giving the impression to the user that data is missing / has been deleted
Comment 11 stragu 2021-06-19 13:36:44 UTC
This is actually the same issue as Bug 35923 : autofilter / standard filter both extend the range to contiguous cells below the selected range.

*** This bug has been marked as a duplicate of bug 35923 ***