Download it now!
Bug 85797 - text box in a drawing object doesn't resize well
Summary: text box in a drawing object doesn't resize well
Status: RESOLVED DUPLICATE of bug 59758
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shape-Textbox
  Show dependency treegraph
 
Reported: 2014-11-03 12:20 UTC by rydberg
Modified: 2020-03-12 12:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of the affected drawing (16.46 KB, application/vnd.oasis.opendocument.text)
2014-11-03 12:20 UTC, rydberg
Details
Example of the affected drawing (14.57 KB, application/vnd.oasis.opendocument.graphics)
2014-11-03 16:54 UTC, rydberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rydberg 2014-11-03 12:20:25 UTC
Created attachment 108832 [details]
Example of the affected drawing

I've created a drawing in LibreOffice Draw, then copied it to Writer. When I want to resize the drawing in the Writer the text boxes don't scale, i.e. the font size doesn't change at all. There's a drwaing in the attached document, when I want to resize it, the F1, F2 and gamma font size doesn't change (stays 18 pt all the time, regardless the drawing size). Visible especially while shrinking.
Comment 1 tommy27 2014-11-03 12:43:00 UTC
I confirm bug under Win7x64 using LibO 3.3.3, 4.3.2 and recent 4.4.0 daily build.
same issue with OOo 3.3.0

is the scaling issue present in the original Draw file or only in the pasted Writer version you attached here?
Comment 2 Cor Nouws 2014-11-03 12:48:07 UTC
Hi rydberg,

(In reply to rydberg from comment #0)

> I've created a drawing in LibreOffice Draw, then copied it to Writer. 

How did you paste it in Writer?

> When I
> want to resize the drawing in the Writer the text boxes don't scale, i.e.
> the font size doesn't change at all. 

That is the same when you resize a shape in Draw..

When you paste as graphic in Writer, you won't have that problem..
Does that help?

Cheers
Cor
Comment 3 rydberg 2014-11-03 16:54:42 UTC
Created attachment 108852 [details]
Example of the affected drawing
Comment 4 rydberg 2014-11-03 16:58:45 UTC
The same problem exist in Draw: when I click and drag one of the corners of the drawing to change its size, the font size doesn't change (see the second attachement). I use a combination of Ctrl+C and Ctrl+V to copy a drawing to Writer.
Comment 5 tommy27 2014-11-03 18:22:39 UTC Comment hidden (obsolete)
Comment 6 rydberg 2014-11-04 00:51:16 UTC
(In reply to tommy27 from comment #5)
> please take a llok at Bug 34467: FORMATTING Fit to Frame for text boxes is
> broken
> 
> tell if it's the same issue (in this case mark your report as RESOLVED
> DUPLICATE) or a different one (then revert status to NEW).

No, it's not the same. I tried to reproduce that bug in the attached file, but every text box seemed to work ok (LibreOffice 4.3.3.2). Please have a look at my attachments and try and rescale the drawing - you'll see what I mean.
Comment 7 tommy27 2014-11-04 03:52:30 UTC
Ok, a different issue. however correct version field is inherited from OOo since it's reproducible on OOo as well (see comment 1). the version field alwaya has to indicate the earliest version a bug appeared so please don't change it again
Comment 8 tommy27 2016-04-16 07:28:06 UTC Comment hidden (obsolete)
Comment 9 Telesto 2016-12-28 19:05:29 UTC
Still reproducible with:
Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: nl-NL (nl_NL); Calc: CL
Comment 10 QA Administrators 2017-12-29 03:28:52 UTC Comment hidden (obsolete)
Comment 11 rydberg 2019-01-28 21:54:07 UTC
I've tested the attached files under LibreOffice 6.1.4.2. The bug still exists.
Version: 6.1.4.2
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU Threads: 4; OS:Linux 4.15; UI render:default; VCL: kde4; 
Locale: pl-PL (pl_PL.UTF-8); Calc: CL
Comment 12 Timur 2020-03-12 12:27:36 UTC
Repro 7.0+. Looks like a duplicate of bug 59758

*** This bug has been marked as a duplicate of bug 59758 ***