Bug 85816 - Website - Please describe difference between Fresh and Still on download page
Summary: Website - Please describe difference between Fresh and Still on download page
Status: RESOLVED DUPLICATE of bug 62592
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ci-infra (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-03 18:53 UTC by paul@anastrophe.com
Modified: 2019-03-15 04:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paul@anastrophe.com 2014-11-03 18:53:04 UTC
Simple request for the LibreOffice download page. It is not truly intuitive what "Fresh" and "Still" mean with regard to which version an end-user should download. Not at all clear, really. But what is worse - the respective download pages do not in any way describe what the difference is! The release notes similarly do not specifically identify what the difference is. *I* know what the difference is, but I actually had to poke around in the community site to eventually learn the difference ("Fresh" is _fairly_ clear, but "Still"? Not at all. "Stable" is immediately understandable).

I would really recommend simply adding the following (or similar words) to each download page:

"Fresh" is our latest release which may contain new features (and possibly some bugs). "Still" is our current stable release, good for all users.

Thanks for your time!
Comment 1 tommy27 2014-11-03 19:47:07 UTC
(In reply to paul@anastrophe.com from comment #0)
> ....
> 
> I would really recommend simply adding the following (or similar words) to
> each download page:
> 
> "Fresh" is our latest release which may contain new features (and possibly
> some bugs). "Still" is our current stable release, good for all users.
> 

I agree. Looks reasonable.
Comment 2 chs 2014-11-04 16:47:32 UTC
Please see the ongoing work happening for this on our RedMine tracker #

Since a few months Bugzill IS NOT USED for anything not directly related to LibreOffice code. 

Thanks!

*** This bug has been marked as a duplicate of bug 62592 ***
Comment 3 chs 2014-11-04 16:48:31 UTC
Sorry, the tracker issue on RedMine is: #793
Comment 4 V Stuart Foote 2014-11-04 17:01:50 UTC
Sure, and it is an issue in the LibreOffice Marketing project. Here is a link: https://redmine.documentfoundation.org/issues/793
Comment 5 paul@anastrophe.com 2014-11-04 18:46:39 UTC
Okay, well, it would probably be helpful if there were a simple 'contact webmaster' link somewhere on the libreoffice pages, so that an end-user wouldn't make this mistake. Sorry for the inappropriate use of bugzilla. I could find no other mechanism for bringing this to the site's attention.
Comment 6 Adolfo Jayme 2014-11-04 19:58:43 UTC
Don't worry, the important thing is that your point came across. I agree that the website could do a better job explaining that this is reserved for bugs in the product and does not handle infrastructure issues.