Bug 85883 - FILESAVE: XLSX file converted from XLS contains invalid XML data
Summary: FILESAVE: XLSX file converted from XLS contains invalid XML data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-05 01:22 UTC by Victor
Modified: 2015-04-30 20:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original file (64.00 KB, application/vnd.ms-excel)
2014-11-05 01:22 UTC, Victor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victor 2014-11-05 01:22:56 UTC
Created attachment 108922 [details]
Original file

I used XML validator on sample document from the net (http://www.columbia.edu/~dj114/excel-examples.xls) after having some issues with parsing XML contents of the file.
XML Parser finds redefined attribute and stops on it.

I converted the document by saving it in XLSX format, then I also tried to convert it using this command to check if there would be some difference:
"soffice.exe --headless --convert-to xlsx:"Calc MS Excel 2007 XML" --outdir output_dir in.doc"
I had the same result regardless of the way I convert this file.

This problem could be simply reproduced by checking the contents of XLSX file in "/xl/drawings".
Libre Office defines type attribute for "v:shape" two times.

I checked this problem on Win 7 64 and Gentoo.
Comment 1 Julien Nabet 2014-11-05 20:29:19 UTC
15 vml are generated, in which one there's a dup?
Also, could you give a try to last stable LO version 4.3.3?
Comment 2 Markus Mohrhard 2015-04-30 20:38:27 UTC
Can't reproduce that issue. I suppose this is fixed.