Bug 85909 - EDITING: Native tables visualization not refreshed after changes to borders
Summary: EDITING: Native tables visualization not refreshed after changes to borders
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.3.1 rc
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.3.6 target:5.4.2
Keywords:
: 56778 64498 94556 100308 111750 111986 (view as bug list)
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2014-11-05 09:56 UTC by ZioTibia81
Modified: 2017-08-25 14:53 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ZioTibia81 2014-11-05 09:56:40 UTC
- Open a new empty project on draw
- Insert -> table (No matter how many rows or columns)
- Select entire table or some cells
- Right click -> Table -> Borders
- Change something about border (Color, size or remove some borders)
- Click OK and you can see that nothng has changed on the table.

A) - Save ODG file
   - Close Draw
   - Reopen Draw and last saved OGD
   - The tables has borders changed

B) - Reselect entire table or some cells
   - Right clock -> Table
   - Change whatever you want on Fonts or Background tabs
   - Click ok
   - The table has new setting for fonts/backgroud and now the bordes are correct.
Comment 1 Buovjaga 2014-11-16 11:01:38 UTC
Reproduced. Changed severity per flowchart: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 2 Buovjaga 2015-01-09 14:56:55 UTC
Bug seems to be Windows-only. Not reproducible on Linux.

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 9763b55eb946cf425220d26dab91bf220890b180
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-08_12:56:53

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 3 David 2015-09-06 23:32:00 UTC
Sorry, this problem has been an issue in linux for ages. I've avoided using tables in Draw because of the inability to get the table borders to work as expected.

Now I am in a position where I have to use a table and wow, the issue is still present.

Select a cell. Click border. Sometimes it turns on. Sometimes it doesn't. Sometimes changing the cell background colour suddenly makes the invisible border show.  Sometimes selecting several adjacent cells and turning on a border makes the individual borders show.

It is something to do with the way LO refreshes the display after borders are turned on or off. It's so unpredictable it is almost unusable.
Comment 4 David 2015-09-06 23:35:19 UTC
I should add that after adding borders, a restart of LO Draw usually shows them correctly. But it sure is frustrating having to keep restarting the application just to see the borders.
Comment 5 David 2015-09-07 00:47:15 UTC
Here's something else. Changes to tables don't seem to be recorded in Draw's FIFO UNDO queue.
Comment 6 Buovjaga 2015-09-07 05:08:55 UTC
David: are you using LibreOffice 5.0.1?
Comment 7 Heiko Tietze 2016-06-14 07:15:41 UTC
Looks good in 5.2. Please double check.
Comment 8 Heiko Tietze 2016-06-14 07:51:27 UTC
*** Bug 100308 has been marked as a duplicate of this bug. ***
Comment 9 Heiko Tietze 2016-06-14 07:52:01 UTC
(In reply to Heiko Tietze from comment #7)
> Looks good in 5.2. Please double check.

Following the screencast from tdf#100308 [1] I can confirm the issue with border color. It works when the color was explicitly set, for instance changing from red to green will undo back to red, but not when the border was undefined.

[1] https://drive.google.com/open?id=0B7DwxkAzR4hsb1MyZHp2REYyOE0
Comment 10 jc.furest 2016-06-14 15:27:04 UTC
I can reproduce this behaviour also in 5.3.0.0.Alpha+
In my concern this not of trivial importance since I use the tables a lot and it is very painful to setup good looking tables if you don't see what you changed.
Comment 11 Buovjaga 2016-06-14 15:56:14 UTC
Ok you convinced me to up severity to minor.
Comment 12 Regina Henschel 2017-08-13 14:56:40 UTC
*** Bug 111750 has been marked as a duplicate of this bug. ***
Comment 13 Regina Henschel 2017-08-13 14:57:14 UTC
*** Bug 56778 has been marked as a duplicate of this bug. ***
Comment 14 Regina Henschel 2017-08-13 15:04:26 UTC
*** Bug 64498 has been marked as a duplicate of this bug. ***
Comment 15 Regina Henschel 2017-08-13 15:06:10 UTC
Bug 64498 contains some discussion about commits, which might have influenced the faulty behavior.
Comment 16 Regina Henschel 2017-08-13 15:22:26 UTC
*** Bug 94556 has been marked as a duplicate of this bug. ***
Comment 17 Regina Henschel 2017-08-13 15:23:44 UTC
Please see bug 94556 for further ideas, especially some further workarounds, which seem to help in some situations.
Comment 18 Buovjaga 2017-08-13 15:28:36 UTC
We should test all border bugs after Armin finishes his rework.
Comment 19 Tamás Zolnai 2017-08-13 15:41:18 UTC
(In reply to Buovjaga from comment #18)
> We should test all border bugs after Armin finishes his rework.

It's not related to Armin's work, since it's not a bug about the borders, but the update mechanism of draw/impress tables.

Anyway, I already added a fix, waiting for jenkins:
https://gerrit.libreoffice.org/#/c/41116/

I'll backport it after pushed to master.
Comment 20 Commit Notification 2017-08-13 16:30:19 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f72879a8e54e18f3ad587f7284b84db592c8d1a

tdf#85909: EDITING: Native tables visualization not refreshed

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2017-08-16 10:25:20 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=296a15773bec15c6aedec1a6be7b938fb60adc58&h=libreoffice-5-3

tdf#85909: EDITING: Native tables visualization not refreshed

It will be available in 5.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2017-08-23 14:38:37 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e96856b791b74e941130b32c1b7f2f1587a349c6&h=libreoffice-5-4

tdf#85909: EDITING: Native tables visualization not refreshed

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Regina Henschel 2017-08-24 08:24:24 UTC
*** Bug 111986 has been marked as a duplicate of this bug. ***
Comment 24 Buovjaga 2017-08-25 14:53:55 UTC
Confirmed fix.

Win 10
Version: 6.0.0.0.alpha0+ (x64)
Build ID: 8d74698f407de0b02826777d5cb3f5aca2fd50f1
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-08-24_23:26:55
Locale: fi-FI (fi_FI); Calc: group