Download it now!
Bug 86096 - Inserted images do not show up before the sheet is scrolled - 2
Summary: Inserted images do not show up before the sheet is scrolled - 2
Status: RESOLVED DUPLICATE of bug 87820
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-11-10 08:03 UTC by Kevin Suo
Modified: 2015-03-19 07:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
image 1 to be used (4.57 KB, image/png)
2014-11-10 08:04 UTC, Kevin Suo
Details
image 2 to be used (45.58 KB, image/png)
2014-11-10 08:04 UTC, Kevin Suo
Details
ODT file with the two png images (78.16 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-11-10 08:11 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-11-10 08:03:38 UTC
A similar issue was reported in bug 81268 which was closed as WORKSFORME.
However now I can reproduce this issue from a new file.

Steps:
1. New spreadsheet file;
2. Insert the attached two png images to sheet1;
3. Save and reopen.

-> Images not loaded when open the file. Scrolling up and down will make the images show up.

Win7,
LibreOffice 4.3.2.2
Build ID: 9bb7eadab57b6755b1265afa86e04bf45fbfc644
Comment 1 Kevin Suo 2014-11-10 08:04:08 UTC
Created attachment 109195 [details]
image 1 to be used
Comment 2 Kevin Suo 2014-11-10 08:04:28 UTC
Created attachment 109196 [details]
image 2 to be used
Comment 3 Kevin Suo 2014-11-10 08:11:33 UTC
Created attachment 109197 [details]
ODT file with the two png images

Note: To reproduce, please make sure Calc window is MAXIMIZED when the file is open. When you open the file bug Calc window is minimized, you do not reproduce this issue.

(P.S. If you already have an open LibreOffice window at minimized state, then open the attached file will cause the file be open minimized.)
Comment 4 Kevin Suo 2014-11-10 08:12:30 UTC
(In reply to Kevin Suo from comment #3)
> When you open the file bug Calc window is minimized...
When you open the file *but* Calc window is minimized...
Comment 5 Kevin Suo 2014-11-10 08:14:05 UTC
A user may think that his/her images are lost, if they are not aware that they should scroll up and down. So this is a major bug.
Comment 6 Cor Nouws 2014-11-10 10:03:54 UTC
Confirmed.

Thanks Kevin for the clear test file.

I opened the attachment in comment 3 as you instructed and confirm the problem.

(I do see it with some other file myself. Then simple up/down on the key board helps.)
Comment 7 Matthew Francis 2015-03-19 07:58:00 UTC
Fixed on bug 87820

*** This bug has been marked as a duplicate of bug 87820 ***