Bug 86100 - FILEOPEN Excel 2003 XML: DateTime cells imported wrong
Summary: FILEOPEN Excel 2003 XML: DateTime cells imported wrong
Status: RESOLVED DUPLICATE of bug 103024
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
Depends on: 86097
Blocks: MSO-XML2003
  Show dependency treegraph
Reported: 2014-11-10 09:41 UTC by Urmas
Modified: 2018-11-21 13:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2014-11-10 09:41:50 UTC
+++ This bug was initially created as a clone of Bug #86097 +++

Well, it is a simple Excel-sheet with some formulas but without any [specials].
If I open the file with LibreOffice Calc, most things looks like in Excel - but there are two exeptions:

- Date-Values where not imported or interpretation failed.
Comment 1 Urmas 2014-11-10 09:42:06 UTC
Still in 4.4.
Comment 2 Cor Nouws 2014-12-21 20:54:37 UTC
Hi Urmas,

Do you know if this worked correct before??
Comment 3 Urmas 2014-12-22 11:07:47 UTC
I have no idea.
Comment 4 Thomas Krumbein 2014-12-22 12:35:41 UTC
well - it doesn´t work the past three years.

If it ever works correkt with OpenOffice.org, I do not know, but I can check with OOo 3.2.1 if nessessary.
Comment 5 QA Administrators 2016-01-17 20:03:28 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-03-06 14:09:34 UTC Comment hidden (obsolete)
Comment 7 Marten Feldtmann 2017-06-22 18:05:11 UTC
Here under Linux/64 LibreOffice I found, that the date part is imported, but the time part is lost (and therefore always be 00:00:00).

Totally unuseable this filter - there are even problems when importing boolean values
Comment 8 QA Administrators 2018-11-17 03:46:54 UTC Comment hidden (obsolete)
Comment 9 Thomas Krumbein 2018-11-20 14:52:50 UTC
different behaviour now in LO, Win 10 (64)

File opens proper, date-values will be recognized correct but shown as number format.

so, format musst changed manual to date-format - the figures are correct.
Comment 10 Timur 2018-11-20 16:59:39 UTC
Which file? Report is not clear. 
From previous comment I conclude this could be now a duplicate of Bug 103024 see Comment 6.
Comment 11 Thomas Krumbein 2018-11-20 17:30:10 UTC
@ Timor: Sorry, my note was going back to the original bug #86097 

so, I got this announcement from QA Adminstrator and checked it with an orginal file - so this was the result.

In Bug #86097 there was mentioned 2 bugs : 1. Date-Values, 2. Formular-values.

Formular-values was fixed before, date-values still was open. 

This is now nearly fixed - only format is wrong.
Comment 12 Timur 2018-11-21 10:57:50 UTC
Can you please write which file opens wrong, like "attachment 123"?
And confirm whether the remaining issue is the same as in Bug 103024: Date format not recognized in a column and opened as general number?
Comment 13 Thomas Krumbein 2018-11-21 11:16:27 UTC
Hi Timur,

well, all Infomations can be found in Bug #86097. 

This is not the same bug as descriped in Bug #103024 !! I cannot give any information to this bug. 

But back to bug #86097 : See pic "file open in calc" (attachment 2) - Date-values where always imported as "0" - but with right cell-format.

Now: Date value is correct, (i.e. 43213) but cell format is wrong (numeric) - changing to "date", everythig is ok.

File is attachment 4 in Bug #86097 (original Excel file).

Hope, this helps you.

btw: I have tested it with a actual file provided by Amazon - maybe the have changed there output? But: in Version LO 5.3.x it is still not working  (as descriped in bug #86097) , in Lo 6.1.3 values will be shown.

best regrads
Comment 14 Timur 2018-11-21 13:43:25 UTC
attachment 109201 [details] is there as xls although it's xml.
This IS the issue from Bug #103024. 
Let's close this bug.

*** This bug has been marked as a duplicate of bug 103024 ***