Bug 86159 - TOOLBAR: drop downs not having sufficient GUI padding on the right and bottom
Summary: TOOLBAR: drop downs not having sufficient GUI padding on the right and bottom
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: highest major
Assignee: Not Assigned
QA Contact: Caolán McNamara
URL:
Whiteboard: target:4.5.0 target:4.4.2
Keywords:
: 84595 87745 88621 (view as bug list)
Depends on:
Blocks: Color-Picker-Widget Toolbars mab4.4
  Show dependency treegraph
 
Reported: 2014-11-11 14:45 UTC by Yousuf Philips (jay)
Modified: 2017-10-22 20:30 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
undo and color drop downs (21.08 KB, image/png)
2014-11-11 14:45 UTC, Yousuf Philips (jay)
Details
Colour chooser in windows Xp (33.33 KB, image/jpeg)
2014-11-21 09:13 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-11 14:45:18 UTC
Created attachment 109278 [details]
undo and color drop downs

The undo/redo drop downs and the color drop downs all have insufficient space at the rigth and bottom.

Version: 4.4.0.0.alpha1+
Build ID: d59b9b4af36148e4d8df8f3e3492116d378642e2
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-06_00:36:43
Comment 1 Adolfo Jayme 2014-11-12 15:51:58 UTC
*** Bug 86207 has been marked as a duplicate of this bug. ***
Comment 2 Jaise James 2014-11-21 09:13:03 UTC
Created attachment 109795 [details]
Colour chooser in windows Xp
Comment 3 V Stuart Foote 2014-12-03 16:47:53 UTC
*** Bug 84595 has been marked as a duplicate of this bug. ***
Comment 4 Yousuf Philips (jay) 2014-12-27 13:42:03 UTC
*** Bug 87745 has been marked as a duplicate of this bug. ***
Comment 5 Adolfo Jayme 2015-01-17 14:14:18 UTC
Added to MAB and increased importance accordingly, based on the number of duplicates and the high visibility of the issue.
Comment 6 V Stuart Foote 2015-01-17 15:14:47 UTC
The term is "padding", and it needs to be increase by about 5px for right edge and bottom edge to provide margins for elements of these drop down widgets--to prevent cropping and provide visual balance. Bug 84595 is the more troublesome manifestation as the button for the color picker launcher can actually be cropped with some OS and DE.
Comment 7 Commit Notification 2015-02-13 16:49:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1f38b47c29ef5e2db2cabeb657668637d97e13d

Resolves: tdf#86159 floating windows have complicated borders

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2015-02-13 16:57:33 UTC
A conservative patch that just affects just the floating windows that I can safely backport to 4-4. 4-4 review at https://gerrit.libreoffice.org/14480
Comment 9 Adolfo Jayme 2015-03-14 01:17:21 UTC
Fix verified in 4.4.2 RC1.

I’ve submitted https://gerrit.libreoffice.org/#/c/14862/ to the libreoffice-4-4 branch in order to remove an ugly, superflous separator widget in the bottom of the dropdown, which was presumably added to lessen the bug before it was fixed properly by Caolán (the widget wasn’t visible before his fix).
Comment 10 Adolfo Jayme 2015-05-22 16:37:26 UTC
*** Bug 88621 has been marked as a duplicate of this bug. ***