Bug 86198 - .ui based toolbar popups sometimes not visible under Linux
Summary: .ui based toolbar popups sometimes not visible under Linux
Status: RESOLVED DUPLICATE of bug 90155
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 86197 86596 86912 89006 89251 89279 89370 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-12 14:11 UTC by Gabriel Diosan
Modified: 2015-06-18 10:05 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of font colour picker not visible on Ubuntu Gnome (105.66 KB, image/png)
2014-11-12 14:11 UTC, Gabriel Diosan
Details
Screenshot showing colour picker in KDE overlapping button (251.58 KB, image/png)
2014-11-13 14:30 UTC, Gabriel Diosan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Diosan 2014-11-12 14:11:22 UTC
Created attachment 109338 [details]
Screenshot of font colour picker not visible on Ubuntu Gnome

The new colour picker is not visible when clicking on "Font Colour", "Background Colour", "Highlighting" and "Line Colour".

Steps to reproduce:

1. Open Libreoffice Writer.
2. Click on "Font Colour", "Background Colour", "Highlighting" or "Line Colour".

Current Behaviour:

The button is pressed but th colour picker is not visible. If you click on roughly were the colour picker would be, the colours are changed. So the colour picker is open but for some reason not visible. Other similar dropdowns such as the bullets and numbering ones are visible and work correctly.

Expected Behaviour:

The colour picker should be visible to the user.

Additional Notes:

I have tested this on the following setups with varying results:

Ubuntu Gnome 15.04 AMD Radeon R7 260X RadeonSI driver - colour picker is not visible

Ubuntu 14.04.1 (Unity) Intel HD4600 Mesa 10.1.3 - colour picker is visible

Lubuntu 14.04.1 (Virtualbox VM) - colour picker is visible

Kubuntu 14.04.1 (Virtualbox VM) - colour picker is visible but is detached from the button (opens in the middle of the screen for example).

So, the issue/s crops up with certain Linux desktops and perhaps only certain hardware/drivers. It would be great if others could test some more Linux desktops and hardware/driver combinations to get a better picture of the problem.

I have attached a picture from by Ubuntu Gnome install to show the problem.

Tested with Libreoffice:

Version: 4.4.0.0.alpha2+
Build ID: 98f9baa5253f7bb8034f148519f31f548b1452fa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-12_00:13:54
Comment 1 sophie 2014-11-12 14:43:17 UTC
*** Bug 86197 has been marked as a duplicate of this bug. ***
Comment 2 sophie 2014-11-12 14:45:31 UTC
Hi, Reproduced with:
Version: 4.4.0.0.alpha2+
Build ID: 98f9baa5253f7bb8034f148519f31f548b1452fa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-12_00:13:54 Ubuntu 14.10 x64. 
As said on the dup, it even freezes my computer sometimes.
Set as New - Sophie
Comment 3 Maxim Monastirsky 2014-11-12 15:11:26 UTC
Hi Gabriel,

Could you please open /opt/libreofficedev4.4/share/config/soffice.cfg/svx/ui/colorwindow.ui in your favorite text editor, and set the "Visible" flag of the GtkWindow to "False" instead of "True" (currently it's on line 15)? Does it make any difference? I observed similar problems under KDE after it was set to "True" in Bug 84676.
Comment 4 Gabriel Diosan 2014-11-12 15:23:28 UTC
Hi Maxim

After changing the value to "False" the colour picker is now visible.

I will test on the Kubuntu VM as well to see if its alignment issues are sort there.

Gabriel
Comment 5 Gabriel Diosan 2014-11-13 14:28:55 UTC
Hi Maxim

I changed the GTKWindow value in my Kubuntu VM and the colour picker now opens attached to the button. However, it sits over the top of the button. I will attach a screenshot to show what I mean.

Gabriel
Comment 6 Gabriel Diosan 2014-11-13 14:30:33 UTC
Created attachment 109416 [details]
Screenshot showing colour picker in KDE overlapping button
Comment 7 Maxim Monastirsky 2014-11-13 14:39:35 UTC
(In reply to Gabriel Diosan from comment #5)
> However, it sits over the top of the button
That's an old bug, reproducible even with 4.3 when using the GTK vcl plugin (see Bug 84142). Let's not mix these different issues together.
Comment 8 Adolfo Jayme Barrientos 2014-11-13 15:52:05 UTC
So far, this bug has been successfully reproduced in GNOME Shell only. So, state that in the bug summary instead of a vague “certain Linux desktop environments”.
Comment 9 Maxim Monastirsky 2014-11-13 15:59:51 UTC
(In reply to Adolfo Jayme from comment #8)
> So far, this bug has been successfully reproduced in GNOME Shell only. So,
> state that in the bug summary instead of a vague “certain Linux desktop
> environments”.
I reproduce it under KDE with both GTK & KDE4 vcl plugins. Trying this with the generic vcl plugin leads sometimes to unexpected closing of the app, especially with the undo-redo popups. See my comments in Bug 84676.
Comment 10 Maxim Monastirsky 2014-12-01 19:16:44 UTC
*** Bug 86912 has been marked as a duplicate of this bug. ***
Comment 11 Gabriel Diosan 2014-12-20 14:10:49 UTC
I have tested the latest Libreoffice Dev 4.5 build and this problem is still present. For people using Gnome Shell, this makes Libreoffice very difficult to use.

Should the importance of this bug be elevated to high or highest? Also, I would say that it should be a blocker for the 4.4 release as users on Gnome Shell will basically not be able to use the colour pickers. Happy for anyone else to provide their thoughts. 

Would love to see this fixed in time for 4.4.0.

Tested on:

Version: 4.5.0.0.alpha0+
Build ID: 2116f1cfb31e5fcf829c2f101cd878a32b56c365
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-19_05:59:03
Locale: en_AU

Ubuntu Gnome 15.04 daily

Gabriel
Comment 12 Adolfo Jayme Barrientos 2014-12-20 21:51:32 UTC
(In reply to Gabriel Diosan from comment #11)
> I have tested the latest Libreoffice Dev 4.5 build and this problem is still
> present. For people using Gnome Shell, this makes Libreoffice very difficult
> to use.

I used GNOME Shell 3.14 and LibreOffice 4.4.0.2 and wasn’t able to reproduce it, interestingly. All pop-ups (including color pickers and the undo/redo list) open correctly for me.

> Should the importance of this bug be elevated to high or highest?

Changing the importance field won’t matter at all, since all developers work on bugs as time permits.
Comment 13 Gabriel Diosan 2014-12-21 02:47:00 UTC
Hmmmm. I am currently using LibreofficeDev on Gnome-Shell 3.12.2. Maybe there was a change between 3.12.2 and 3.14 that fixes the problem.

I will check again once the Ubuntu 15.04 dailies pull in 3.14 to see if the problem is still present.

Thanks for following up Adolfo.
Comment 14 Severo Raz 2015-01-31 17:54:30 UTC
I am using Ubuntu GNOME 14.10 (Gnome Shell desktop) amd64 with nVidia GPU 8600M GT and proprietary drivers versioned 331.113, and I can reproduce this issue.

However, after performing the workaround proposed in comment #3, the colorpicker is shown on request.
Comment 15 Adolfo Jayme Barrientos 2015-02-11 04:04:04 UTC
*** Bug 89251 has been marked as a duplicate of this bug. ***
Comment 16 Viko Adi Rahmawan 2015-02-11 04:13:40 UTC
*** Bug 89006 has been marked as a duplicate of this bug. ***
Comment 17 davidfabijan 2015-02-11 10:01:57 UTC
*** Bug 89279 has been marked as a duplicate of this bug. ***
Comment 18 Walid Moghrabi 2015-02-11 15:20:49 UTC
Confirmed that comment #3 fixed the problem here (Ubuntu 14.04 + Gnome 3.12)
Comment 19 Jean-Baptiste Faure 2015-02-14 09:52:39 UTC
*** Bug 89370 has been marked as a duplicate of this bug. ***
Comment 20 Murat Ursavaş 2015-02-15 15:16:36 UTC
I can confirm that this bug still exists in 4.4.0.3. The solution in comment 3 also worked for me but the file is in a different path, which is, 

/usr/lib/libreoffice/share/config/soffice.cfg/svx/ui/colorwindow.ui

I'm using elementary OS Freya Beta 2 and installed LibreOffice via PPA.
Comment 21 niklas.s.rosenqvist 2015-03-10 09:46:40 UTC
Guys, this is a pretty serious bug, for me it even crashes sometimes because of this but the workaround mentioned fixes it. Can the priority be elevated so that it gets fixed?
Comment 22 Adolfo Jayme Barrientos 2015-03-24 06:46:53 UTC
*** Bug 86596 has been marked as a duplicate of this bug. ***
Comment 23 Christian Seemann 2015-03-31 10:02:56 UTC
I can confirm the bug as well:

LibreOffice 4.4.1.2
Linux 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET 2015 x86_64 GNU/Linux
Window manager: AwesomeWM

Maxim's workaround in Comment #3 shows the color picker again.

-Christian
Comment 24 Olivier Lenoir 2015-04-01 17:26:48 UTC
I confirm this bug on 4.4.2.2
Envt : Ubuntu 14.10, Gnome
Comment 25 elthommo 2015-04-13 20:37:14 UTC
I have this bug in Ubuntu Gnome 14.04.2 LTS 64-bit
Gnome-shell Version 3.12.2

LibreOffice version :
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_GB
Comment 26 elthommo 2015-04-13 20:59:25 UTC
The fix in comment 3 works however for me, the file to be edited was in a different location.

/usr/lib/libreoffice/share/config/soffice.cfg/svx/ui/colorwindow.ui

and set the "Visible" flag of the GtkWindow to "False" instead of "True"

line 15 for me too.
Comment 27 sergei 2015-04-19 02:40:57 UTC
I ran into the problem in Elementary OS Freya with version 4.4.2.2 build 40m0 (Build:2)
Comment 28 aisyk 2015-05-06 15:32:47 UTC
I have this issue too.

(Elementary-OS FREYA)

The fix in Comment 26 is ok for me : https://bugs.documentfoundation.org/show_bug.cgi?id=86198#c26
Comment 29 Caolán McNamara 2015-06-18 10:05:23 UTC

*** This bug has been marked as a duplicate of bug 90155 ***