Bug 86222 - UI: Large unused space the picture dialogue box
Summary: UI: Large unused space the picture dialogue box
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.4.0 target:4.3.5
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-12 22:17 UTC by A (Andy)
Modified: 2015-05-02 12:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot 4.2.x vs 4.3.x (34.11 KB, image/png)
2014-11-13 03:42 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-11-12 22:17:10 UTC
There is a large unused space in the picture dialogue box.

Steps to Reproduce:
1. Open WRITER
2. Insert any picture (INSERT -> IMAGE -> FROM FILE)
3. Make a right mouse click on the picture and go to PICTURE -> tab TYPE

Result:
There is a large unused space between the sections Size and Position.

Reproducible with LO 4.3.3.2, Win 8.1.
Comment 1 tommy27 2014-11-13 03:42:05 UTC
Created attachment 109376 [details]
screenshot 4.2.x vs 4.3.x

confirmed under Win7x64
Image option window is bigger in 4.3.x and has that gap size and position

see comparative screenshot between 4.2.0 and 4.3.3
I see the same thing in 4.2.6 and 4.3.0
hence it's a 4.3.x regression
Comment 2 Adolfo Jayme 2014-11-13 07:52:17 UTC
CCing Caolán, since I’ve tried to fix this and didn’t know how :-/

Either the Macro or Background tabs seem to be the culprits of over-stretching the rest of tab pages.
Comment 3 Caolán McNamara 2014-11-15 16:35:01 UTC
Its the event assignment page, hard-coded pixel heights/widths have made their way into the .ui file
Comment 4 Commit Notification 2014-11-15 17:33:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7402886d42035873e7d7cb3a30582e9001217bf

Related: fdo#86222 rework area graphic fill page for better height

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-11-15 17:33:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6db5e6a2a2ac7f92e6d15669693d991c9460998

Resolves: fdo#86222 hard-coded pixel dimensions are too high/wide

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2014-11-15 17:41:36 UTC
https://gerrit.libreoffice.org/12461 for 4-3
Comment 7 Caolán McNamara 2014-11-15 17:42:57 UTC
The bitmap was a little high too, though it was mostly the event assigner, reworked the bitmap to be a little less tall and wide as well.
Comment 8 Adolfo Jayme 2014-11-23 16:17:20 UTC
Backported to 4-3 as 298ca08e. Thanks!
Comment 9 Adolfo Jayme 2015-05-02 12:56:55 UTC
*** Bug 80951 has been marked as a duplicate of this bug. ***