Bug 86238 - EDITING: LO crashes when opening document properties
Summary: EDITING: LO crashes when opening document properties
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-13 07:55 UTC by Denis
Modified: 2016-04-18 09:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denis 2014-11-13 07:55:30 UTC
Hi All!

1. Open new (blank) document (writer or calc), open File-Properties -> CRASH
2. Open existing document (XLS, XLSX, ODS), open File-Properties -> CRASH

LO 4.3.3.2 (build id: 9bb7eadab57b6755b1265afa86e04bf45fbfc644)
OS: MS Windows Server 2012 Standard
Comment 1 raal 2014-11-13 20:10:43 UTC
Unable to reproduce. Win7, version: 4.3.3.2
ID build: 9bb7eadab57b6755b1265afa86e04bf45fbfc644
Comment 2 Jacques Guilleron 2014-11-16 14:28:54 UTC
Hello Denis, Raal,

I didn't reproduce with 
LO 4.3.3.1 Build ID: 7d55112667c8fcddb67bc3803796b46c93aa56b0
LO 4.3.4.0.0+ Build ID: 77c6ce66696a997269b9fe4dfed1dc2e51ecd00e
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-10-17_16:12:56
LO 4.4.0.0.alpha1+ Build ID: a8c24b25fd9fb21097a08a22797bf61b59099ea1
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-21_06:33:33
Under Windows 7 Home Premium.
Did you try to rename your profile?
https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile

regards,

Jacques
Comment 3 Denis 2014-11-16 17:45:10 UTC
I can't rename profile, bacouse it is production terminal server. We tried:

- removing LO profile folder (in %USERPROFILE%\AppData\Roaming) - no results;
- reinstalling LO - no results;
- reboot server (we did it first )) ) - no results.

So, we have removed LO and back to previous version (4.2.7).
Comment 4 Joel Madero 2014-11-16 21:02:40 UTC
So - it seems likely this is based on the profile as now 3 of us can not reproduce. If you cannot test further with a fresh profile I'm afraid there isn't much we can do. 

Are you able to zip the profile and attach it? Setting to NEEDINFO as the information currently provided is not sufficient for anyone to reproduce. If you can at least attach the profile set to UNCONFIRMED. Thank you
Comment 5 Daniel 2015-05-05 13:10:40 UTC
Confirmation of crash status which occurs when File->Properties is selected. Very frustrating (to put it mildly)!
Comment 6 Daniel 2015-05-05 13:15:22 UTC
Also applies to version 4.4.1.2. :(
Comment 7 Joel Madero 2015-05-05 15:11:12 UTC
So another thing that you could do is attach a zip of the profile to this bug....without that I'm afraid we'll have to close the bug as INVALID because no one else can reproduce it and the bug doesn't have the needed information.
Comment 8 Daniel 2015-05-06 18:33:58 UTC
Thanks, Joel. I'm new to sending feedback on bugs, so maybe someone could enlighten me on "profile". Is it generated automatically, or what? If not automatically, what should a profile report contain?

BTW, I reinstalled the latest version, this time after completely removing LO, instead of over an old version of LO. Hmm, I cannot now reproduce this bug. :)
Comment 9 Julien Nabet 2015-11-18 21:58:42 UTC
About the LO directory profile, you'll find the location here:
https://wiki.documentfoundation.org/UserProfile#Windows

So zip the directory and attach it by using this link:
https://bugs.documentfoundation.org/attachment.cgi?bugid=86238&action=enter

But first, please give a new try with last stable LO version 5.0.3
Comment 10 mahfiaz 2016-04-18 09:58:45 UTC
So reinstalling made it work. In that case I am going to close this bug.