Download it now!
Bug 86301 - Link to Help Page of Start Center Broken
Summary: Link to Help Page of Start Center Broken
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.1.0 target:5.0.0.3 target:4.4.6
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-11-14 23:19 UTC by Harald Koester
Modified: 2016-10-25 19:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2014-11-14 23:19:09 UTC
Steps in order to reproduce the bug:

[1] Precondition for this bug is that there is no local help according to the user interface language installed. If this is not the case, either deinstall the local help or choose a language for the user interface, for which no local help is installed.
[2] Start LibreOffice. The Start Center is displayed.
[3] Start Help with F1. In Firefox the page 
https://help.libreoffice.org/swriter/sfx/ui/startcenter/open_all?Language=de&System=WIN&Version=4.3
is displayed. 
Expected: Display of help page “Start Center”. E.g. the german help page for Version 4.2.x: 
https://help.libreoffice.org/swriter/.HelpId:StartCenter:OpenButton?Language=de&System=WIN&Version=4.2#bm_id1022200910595546

Tested also with version 4.2.4: The correct help page is displayed. Hence regression.

BTW if you start the help via the menu a correct help page is displayed, but it is not the same. I think this is intended. But then the menu item “LibreOffice help   F1” is not correct. “F1” has to be omitted.
Comment 1 A (Andy) 2014-11-15 08:24:19 UTC
Reproducible with LO 4.3.3.2, Win 8.1
Comment 2 Pedro 2015-06-23 22:05:58 UTC
This is still broken in branch 4.4 and 5.0

This is a regression from branch 4.2
Comment 3 Andras Timar 2015-07-07 13:25:22 UTC
commit 5aad108719014b52c9aba6be407ed553d0095a66
Author: Andras Timar <andras.timar@collabora.com>
Date:   Tue Jul 7 14:52:38 2015 +0200

    tdf#86301 fix hids of startcenter