Bug 86390 - File Type List has no scrollbar
Summary: File Type List has no scrollbar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scrollbars
  Show dependency treegraph
 
Reported: 2014-11-17 12:45 UTC by baffclan
Modified: 2020-06-19 04:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (177.67 KB, image/jpeg)
2014-11-17 12:45 UTC, baffclan
Details
screenshot(odt) (516.37 KB, application/vnd.oasis.opendocument.text)
2014-11-22 07:43 UTC, baffclan
Details
Windows/LibreOffice dialogs (242.50 KB, application/vnd.oasis.opendocument.text)
2014-12-03 11:22 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2014-11-17 12:45:19 UTC
Created attachment 109616 [details]
screen shot

File Type List (of Open Dialog) has not scroll bar

Steps to Reproduce:
1. start LibreOffice
2. click Open File in SideBar
3. appear Dialog
4. click [All file(*.*)] button
5. appear File Type List

Actual Results: 
File Type List has not scroll bar

Expected Results: 
File Type List has scroll bar
Comment 1 tommy27 2014-11-18 05:51:18 UTC
I correctly see the scrollbar in 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-12_00:19:18

please define your O/S and your master build copying those infos from Help/About LibreOfficeDev
Comment 2 baffclan 2014-11-18 11:59:43 UTC
(In reply to tommy27 from comment #1)
tommy27, thanks for comments.

OS : Windows 7 Professional SP1 (x64)

Libreoffice Version :
Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243

Version: 4.4.0.0.alpha2+
Build ID: 6143fa5a89d9528fc11fed1e7fe96b9280d411a4
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-10_23:27:31
Comment 3 tommy27 2014-11-18 15:09:38 UTC
is the bug happening just with 4.4 alpha or even with 4.3.4.1?
Comment 4 baffclan 2014-11-21 07:40:55 UTC
(In reply to tommy27 from comment #3)
> is the bug happening just with 4.4 alpha or even with 4.3.4.1?
Both.
Reproduce with 4.3.4.1, 4.4a2(master).

and 4.4.0.0.beta1/Windows7(64), too.
Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Comment 5 Jacques Guilleron 2014-11-21 10:39:09 UTC
Hi baffclan,

I don't reproduce, using 
LO 4.3.4.0.0+ Build ID: 77c6ce66696a997269b9fe4dfed1dc2e51ecd00e
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-10-17_16:12:56
LO 4.4.0.0.alpha2+ Build ID: 4f18bd405831c31cd49190046f7bafd805a47d7d
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-20_09:39:04 Locale: fr_FR
& Windows 7 Home Premium
This scroll bar is there.
Did you try to rename your profile?
https://wiki.documentfoundation.org/Documentation/UserProfile#Resetting_the_User-Profile

Jacques
Comment 6 baffclan 2014-11-22 07:43:19 UTC
Created attachment 109837 [details]
screenshot(odt)

Thanks for testing.
I tested other PC with wide screen display.
I found a scroll bar.

Overflow a display when File Type List is too wide.
Comment 7 tommy27 2014-11-22 08:06:20 UTC
so is that a screen resolution issue?
Comment 8 baffclan 2014-11-22 08:21:01 UTC
(In reply to tommy27 from comment #7)
> so is that a screen resolution issue?

Yes, it is a screen resolution issue.
Comment 9 Jacques Guilleron 2014-11-22 15:17:45 UTC
Hi,

In your document, the first screenshot is taken on a 4x3 monitor while the second on a 16x9.
File Type List has to be wholly visible on all these screens.
I set Status to NEW.

Regards,

Jacques
Comment 10 baffclan 2014-12-03 11:22:22 UTC
Created attachment 110403 [details]
Windows/LibreOffice dialogs

Sorry, it is not screen resolution issue.
See attachment ODT file.

Windows dialog has Filename extension.
LibreOffice dialog has not Filename extension.
Comment 11 QA Administrators 2015-12-20 16:09:56 UTC Comment hidden (obsolete)
Comment 12 baffclan 2015-12-21 08:27:50 UTC
Reproduce with newest master.

Windows 7 Pro(x64)
Version: 5.2.0.0.alpha0+ (x64)
Build ID: a454a9b3ae0f6ab81012fbef7b3ff6f0f44bf6cb
Threads 4; Ver: Windows 6.1; Render: GL; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-12-02_06:37:24
Locale: ja-JP (ja_JP)
Comment 13 Adolfo Jayme 2016-03-26 14:45:43 UTC
IMHO we should remove the extensions from the file type list. Showing the extensions there makes the list stupidly, awkwardly wide.
Comment 14 QA Administrators 2018-02-13 03:32:52 UTC Comment hidden (obsolete)
Comment 15 baffclan 2018-07-29 07:21:22 UTC
Reproduce with LibO 6.1/LibO-Dev 6.2.

Version: 6.1.0.2 (x64)
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ja-JP (ja_JP); Calc: group threaded


Version: 6.2.0.0.alpha0+ (x64)
Build ID: d8733e2c59f120acf9feddff04964becc3358621
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2018-06-26_11:09:03
Locale: ja-JP (ja_JP); Calc: group threaded
Comment 16 QA Administrators 2019-07-30 03:16:38 UTC Comment hidden (obsolete)
Comment 17 baffclan 2019-08-12 07:13:35 UTC
Reproduce with LibO 6.3 .

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded
Comment 18 baffclan 2020-06-04 01:56:29 UTC
Cannot reproduce with LibO-Dev 7.0.0.0.B1.

Version: 7.0.0.0.beta1 (x86)
Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: en-US
Calc: threaded
Comment 19 baffclan 2020-06-19 04:56:08 UTC
(In reply to baffclan from comment #18)
> Cannot reproduce with LibO-Dev 7.0.0.0.B1.
> 
> Version: 7.0.0.0.beta1 (x86)
> Build ID: 94f789cbb33335b4a511c319542c7bdc31ff3b3c
> CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL:
> win
> Locale: ja-JP (ja_JP); UI: en-US
> Calc: threaded

-> WORKSFORME