Bug Hunting Session
Bug 86396 - FILESAVE and FORMATTING XLSX loss of scale mode settings after saving
Summary: FILESAVE and FORMATTING XLSX loss of scale mode settings after saving
Status: RESOLVED DUPLICATE of bug 65848
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Repro:5.1
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 14:37 UTC by Mateo
Modified: 2017-06-30 15:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
New Spreadsheet created in 4.3.2.2 (4.17 KB, application/excel)
2014-11-17 14:37 UTC, Mateo
Details
XLSX file created in MS Office scaled to 90% (9.93 KB, application/vnd.openxmlformats-officedocument.spreadsheetxml)
2015-07-27 11:43 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateo 2014-11-17 14:37:06 UTC
Created attachment 109623 [details]
New Spreadsheet created in 4.3.2.2

If you create a new spreadsheet and change the page formatting...scale mode to 50%..save it as an .xlsx (Microsoft Excel 2007/2010/2013 XML) file....close it. After opening the same file, the page scaling is lost. It is back to 100%.
Comment 1 raal 2014-11-19 22:26:30 UTC
I can confirm with Version: 4.4.0.0.alpha2+
Build ID: 2f342c61616418c6ad7303d7f5efa27a28378681
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-16_00:33:40
Comment 2 Mateo 2014-11-20 13:10:26 UTC
I should have included that am using Windows XP, Windows 7, Windows 2008R2 RDS (x64).
Comment 3 Timur 2015-07-27 11:43:27 UTC
Created attachment 117464 [details]
XLSX file created in MS Office scaled to 90%

There are 2 problems with scaling, but let's keep it as a single bug for now:
- fileopen worked OK with OO up to LO 3.5.7, so regression from 3.6.0
- filesave never worked OK, so implementation error in LO 3.3.0
Comment 4 brucehohl 2016-02-26 02:54:46 UTC
This bug still exist at version 5.1.0.3 - 25 Feb 2016.
Comment 5 Mateo 2016-10-25 13:09:21 UTC Comment hidden (obsolete)
Comment 6 brucehohl 2016-10-25 22:40:33 UTC
Bug still exists on LO Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f

1 - Create a new Calc spreadsheet
2 - At Format > Page set 
    'Scaling mode:' = 'Reduce/enlarge printout'
    'Scaling factor' = '90%' (or anything other than 100%)
    Click 'OK'
3 - Save worksheet in xlsx format then close.
4 - Open worksheet, go to Format > Page
    Observe that 'Scaling factor' = '100%'

Thus, 'Scaling factor' is lost".  I also checked this on two recent LO 5.2.x builds one on Windows and one on Linux with same result so I am going to set this back to NEW.
Comment 7 brucehohl 2016-10-25 23:30:41 UTC
*** Bug 103484 has been marked as a duplicate of this bug. ***
Comment 8 Mateo 2016-10-26 12:14:08 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2017-04-01 18:22:34 UTC
*** Bug 106853 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2017-04-02 07:30:23 UTC Comment hidden (obsolete)
Comment 11 Timur 2017-06-30 15:12:53 UTC
Looks fixed with Bug 65848.

*** This bug has been marked as a duplicate of bug 65848 ***