Bug Hunting Session
Bug 86401 - Error after close LibreOffice
Summary: Error after close LibreOffice
Status: RESOLVED DUPLICATE of bug 91214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.5.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 17:12 UTC by Roman Kuznetsov
Modified: 2015-08-17 17:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2014-11-17 17:12:51 UTC
after close LibreOffice 4.4.0 alpha2 (ID 6143fa5a89d9528fc11fed1e7fe96b9280d411a4) Windows (locale RU) displayed error:

Сигнатура проблемы:
  Имя события проблемы:	APPCRASH
  Имя приложения:	soffice.bin
  Версия приложения:	4.4.0.0
  Отметка времени приложения:	546162cb
  Имя модуля с ошибкой:	vcllo.dll
  Версия модуля с ошибкой:	4.4.0.0
  Отметка времени модуля с ошибкой:	5461578b
  Код исключения:	c0000005
  Смещение исключения:	00370495
  Версия ОС:	6.1.7601.2.1.0.768.2
  Код языка:	1049
  Дополнительные сведения 1:	0a9e
  Дополнительные сведения 2:	0a9e372d3b4ad19135b953a78882e789
  Дополнительные сведения 3:	0a9e
  Дополнительные сведения 4:	0a9e372d3b4ad19135b953a78882e789

while restarting the application runs normally
Comment 1 Roman Kuznetsov 2014-11-19 18:51:11 UTC
to replicate the problem, follow these steps: 
Start LibreOffice 4.4 Alpha 2, 
on the start screen, select Create a new document writer,
write a couple of words in the document,
save the document, 
close LibreOffice (not the writer, and the entire program LO)
Comment 2 Roman Kuznetsov 2014-12-04 09:56:30 UTC
after close LibreOffice 4.3.5.1 (ID  8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889) Windows 7 (locale RU) displayed error:

Сигнатура проблемы:
  Имя события проблемы:	BEX
  Имя приложения:	soffice.bin
  Версия приложения:	4.3.5.1
  Отметка времени приложения:	5475cabe
  Имя модуля с ошибкой:	StackHash_0a9e
  Версия модуля с ошибкой:	0.0.0.0
  Отметка времени модуля с ошибкой:	00000000
  Смещение исключения:	be36669d
  Код исключения:	c0000005
  Данные исключения:	00000008
  Версия ОС:	6.1.7601.2.1.0.768.2
  Код языка:	1049
  Дополнительные сведения 1:	0a9e
  Дополнительные сведения 2:	0a9e372d3b4ad19135b953a78882e789
  Дополнительные сведения 3:	0a9e
  Дополнительные сведения 4:	0a9e372d3b4ad19135b953a78882e789

suddenly appeared this problem in version 4.3.5.1 on another computer.
I just edited the text document and save it (the document was saved!). And got this error.
Comment 3 Joel Madero 2014-12-04 19:05:00 UTC
Can you try with a fresh profile: https://wiki.documentfoundation.org/UserProfile
Comment 4 Joel Madero 2014-12-04 19:05:22 UTC
Never independently confirmed - setting to UNCONFIRMED again. Thanks
Comment 5 Roman Kuznetsov 2014-12-04 19:47:40 UTC
(In reply to Joel Madero from comment #4)
> Never independently confirmed - setting to UNCONFIRMED again. Thanks

ok.
Comment 6 Roman Kuznetsov 2014-12-04 19:48:57 UTC
(In reply to Joel Madero from comment #3)
> Can you try with a fresh profile:
> https://wiki.documentfoundation.org/UserProfile

I deleted all LO. And this error appeared on two different computers!
Comment 7 tommy27 2014-12-14 18:12:00 UTC
tested under Win8.1 64 bit using Version: 4.5.0.0.alpha0+
Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46
Locale: it_IT

I see no error after following steps in comment 1
please tell if problem persists in more recent builds and define exactly your Windowa version
Comment 8 Roman Kuznetsov 2014-12-18 20:15:06 UTC
(In reply to tommy27 from comment #7)
> tested under Win8.1 64 bit using Version: 4.5.0.0.alpha0+
> Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
> TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46
> Locale: it_IT
> 
> I see no error after following steps in comment 1
> please tell if problem persists in more recent builds and define exactly
> your Windowa version

today with LO 4.5 alpha0+ ID build: dad173d9588e6abc2a465198b7d2881d4629246a, on Windows 7 x86_64, was such an error again, only in another module. Screenshot not available =(
Comment 9 Joel Madero 2015-02-05 03:44:34 UTC
Setting to UNCONFIRMED but I can't confirm
Comment 10 Dennis Roczek 2015-03-09 13:35:16 UTC
@kompilainenn what hardware do you have? Which Windows version? Do you have old computers (which doesn't have SEE2 - a cpu feature)

so, one pc uses windows 7 - 32 bit or 64 bit? (windows version)
and the other one?
Comment 11 Roman Kuznetsov 2015-03-09 14:03:13 UTC
(In reply to Dennis Roczek from comment #10)
> @kompilainenn what hardware do you have? Which Windows version? Do you have
> old computers (which doesn't have SEE2 - a cpu feature)
> 
> so, one pc uses windows 7 - 32 bit or 64 bit? (windows version)
> and the other one?

1. Intel Pentium G850 / video Nvidia GT640 / 4Gb memory / Windows 7 HB x86
2. Athlon II x2 270 / video Radeon 7750 / 4Gb memory / Windows 7 HB x86-64

older computers do not have in stock
Comment 12 Dennis Roczek 2015-03-09 17:38:10 UTC
(In reply to kompilainenn from comment #11)
> (In reply to Dennis Roczek from comment #10)
> > @kompilainenn what hardware do you have? Which Windows version? Do you have
> > old computers (which doesn't have SEE2 - a cpu feature)
> > 
> > so, one pc uses windows 7 - 32 bit or 64 bit? (windows version)
> > and the other one?
> 
> 1. Intel Pentium G850 / video Nvidia GT640 / 4Gb memory / Windows 7 HB x86
> 2. Athlon II x2 270 / video Radeon 7750 / 4Gb memory / Windows 7 HB x86-64
> 
> older computers do not have in stock

OK, this is definitive not a problem of SSE. :-)

I believe I found the solution - can you try the solution which is proposed in this thread http://portableapps.com/node/36359

@devs can we install the dlls (being more precise vcllo.dll) with the installer? It seems that (at least what I have read) is a win7 (only?) problem...
Comment 13 Roman Kuznetsov 2015-03-09 19:43:57 UTC
> I believe I found the solution - can you try the solution which is proposed
> in this thread http://portableapps.com/node/36359
> 
> @devs can we install the dlls (being more precise vcllo.dll) with the
> installer? It seems that (at least what I have read) is a win7 (only?)
> problem...

link to the start of the LO and I installed dll, about which it says
Comment 14 Dennis Roczek 2015-03-22 22:56:30 UTC
just to clarify: so the problem still exists even after installing / registering the dll, or?
Comment 15 Robinson Tryon (qubit) 2015-03-31 17:25:18 UTC
(In reply to Dennis Roczek from comment #14)
> just to clarify: so the problem still exists even after installing /
> registering the dll, or?

Status -> NEEDINFO
Comment 16 Timur 2015-05-25 09:28:20 UTC
Bug 91214 looks similar. Normally, higher number is a duplicate, but since this Bug 86401is Needinfo, and Bug 91214 is easily reproduced with backtrace, this may be a duplicate.
Comment 17 Timur 2015-05-25 09:30:02 UTC
I will mark as duplicate. Feel free to reopen if proved different or if a fix from 91214 doesn't solve this bug.

*** This bug has been marked as a duplicate of bug 91214 ***