Bug Hunting Session
Bug 86440 - MENUS: Unifying the location of header and footer
Summary: MENUS: Unifying the location of header and footer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: medium enhancement
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:4.5.0 target:4.4.0.0.beta2
Keywords:
: 62546 (view as bug list)
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2014-11-18 15:13 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-04-14 16:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-18 15:13:30 UTC
In writer header and footer is located under the Insert menu, in calc it is in the Edit menu and in impress its in wrongly placed in the View menu.

The View menu in impress was reorganized (bug 86209) and in the bug report Cor, Andy and I briefly discussed the issue. Andy and I agreed that it should be placed in the Insert menu like in writer and Cor said it should be in the Edit menu like in calc.
Comment 1 V Stuart Foote 2014-11-18 15:37:20 UTC
If something were displayed by default then Edit makes sense. Reports in Calc will almost always display header/footer.

But in Impress and Writer, unlike Calc, that is not the norm--so placement on the Insert menu is reasonable UX.

One could then make the case--having moved header/footer for Impress to the Insert menu matching Writer--that to have consistent UI across the components moving Calc's header/footer items to the Insert menu would be reasonable and consistent UX across the components.

IMHO move all header/footer menu items to the same menu--which could be Insert or could be Format.
Comment 2 Cor Nouws 2014-11-18 16:58:12 UTC
For reasons as VStuart gives, I'm not a fan of pushing all on the same heap. Makes little sense, and is not logic.
Comment 3 Yousuf Philips (jay) (retired) 2014-11-21 13:24:48 UTC
We discussed this issue at this week's design meeting and decide to move it Edit for all modules.
Comment 4 Yousuf Philips (jay) (retired) 2014-11-22 10:38:40 UTC
Patch is in - https://gerrit.libreoffice.org/13026
Comment 5 Cor Nouws 2014-11-23 12:32:39 UTC
(In reply to Jay Philips from comment #3)
> We discussed this issue at this week's design meeting and decide to move it
> Edit for all modules.

Sorry I couldn't be there.
Has been considered that people are already lost when they are looking for "Insert > Page number".. The step to Insert > Footer was relatively easy :)
Format > Title page offers page numbering, but only in case you combine it with a title page :p
Comment 6 Yousuf Philips (jay) (retired) 2014-11-23 13:25:28 UTC
(In reply to Cor Nouws from comment #5)
> Sorry I couldn't be there.

Yes you were missed. :D

> Has been considered that people are already lost when they are looking for
> "Insert > Page number"..

Yes i'd assume people would be confused, which is why it is in the toolbar now. :D
Comment 7 Cor Nouws 2014-11-23 13:38:22 UTC
(In reply to Jay Philips from comment #6)
> (In reply to Cor Nouws from comment #5)
> > Sorry I couldn't be there.
> 
> Yes you were missed. :D
> 
> > Has been considered that people are already lost when they are looking for
> > "Insert > Page number"..
> 
> Yes i'd assume people would be confused, which is why it is in the toolbar
> now. :D

"Insert Field" that places a field at the cursor position.
Not the same as "Insert > Footer with page number "(which we don't have at all)
Comment 8 Yousuf Philips (jay) (retired) 2014-11-23 14:22:38 UTC
(In reply to Cor Nouws from comment #7)
> "Insert Field" that places a field at the cursor position.
> Not the same as "Insert > Footer with page number "(which we don't have at
> all)

Yes i had seen that feature in MS Word and thought to suggest it. Should i go for it and CC you. :D
Comment 9 Cor Nouws 2014-11-23 14:30:58 UTC
(In reply to Jay Philips from comment #8)
> (In reply to Cor Nouws from comment #7)
> > "Insert Field" that places a field at the cursor position.
> > Not the same as "Insert > Footer with page number "(which we don't have at
> > all)
> 
> Yes i had seen that feature in MS Word and thought to suggest it. Should i
> go for it and CC you. :D

Why not? But it's a bit more work then rearranging menus. Therefore my concern or reducing 'visibility' of the option for time being.
Comment 10 Commit Notification 2014-11-25 11:31:02 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=452db55f0a14a1f8c77cae7b54f1857498651c28

fdo#86440 move header and footer entry to insert menu

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-11-25 11:31:13 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c8e0f95750e43eda1ca69df48f7b35e5003374b&h=libreoffice-4-4

fdo#86440 move header and footer entry to insert menu

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Yousuf Philips (jay) (retired) 2016-04-14 16:18:12 UTC
*** Bug 62546 has been marked as a duplicate of this bug. ***