Download it now!
Bug 86444 - Add option to show LO version number close to menu bar
Summary: Add option to show LO version number close to menu bar
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-18 20:48 UTC by Timur
Modified: 2015-02-06 23:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2014-11-18 20:48:44 UTC
I propose to add an option to have LO version number in the menu bar (close to update and exit icons).

It'd be useful for:
- multiple and parallel LO installations, and that should be turned on by default in parallel and DEV versions
- normal company deployment installations, where a technician could immediately observe a version without going to Help-About
Comment 1 tommy27 2014-11-18 21:15:44 UTC
it makes sense. when I'm doing QA tests with older versions sometimes I get lost and I have always to take a look at "?/about LibO" menu

I set status NEW. let's see what the ux-advise thinks about it
Comment 2 V Stuart Foote 2014-11-18 22:03:03 UTC
The version number is almost useless. For non release builds, really need the commit ID of the final commit for build. As noted, this detail is already being added for this purpose in Help --> About for *any* open component.

I simply don't see any practical point from UX--or sysadmin/tech support--perspective for this UI addition, suggest a Resolve Wontfix as with similar bug 84898 suggestion to put info in the Start Center.

Stuart
Comment 3 Cor Nouws 2014-11-18 22:09:48 UTC
I understand your idea, Timur.
On Linux I use geany.
For the 443rc2 for example, I did:
genay .config/libreoffice/434rc1/libreoffice4.3/share/registry/main.xcd

Ctrl+F "ooname" Enter Enter
after second position " 434rc1"
Ctrl+S, Ctrl+W, Alt-F4

For the few appreciating this, maybe that is doable?
Comment 4 Michael Meeks 2014-11-19 09:13:07 UTC
I can see this being useful for testers; but I'd never want an end-user to see that =)
Comment 5 tommy27 2014-11-19 10:22:02 UTC
yes Micheal, testers would like it so this should be an option with "default OFF state" that only experienced users shoulobo ds. manually activate
Comment 6 Cor Nouws 2014-11-19 12:07:30 UTC
(In reply to tommy27 from comment #5)
> yes Micheal, testers would like it so this should be an option with "default
> OFF state" that only experienced users shoulobo ds. manually activate

Looking at my comment #3, I would say WorksForMe ... Timur, Tommy?
Comment 7 tommy27 2014-11-19 12:30:39 UTC
it may work with Linux but there are also Windows and MacOS users to think about
Comment 8 Timur 2014-11-19 12:59:48 UTC
(In reply to tommy27 from comment #7)
> it may work with Linux but there are also Windows and MacOS users to think
> about

Right. I would still like this as requested. 
Even that Linux solution is case-by-case, needing manual setup, while I suggest that this comes with "default OFF state" in normal and "default ON state" in LODEV and parallel installation.

This bug seems like a duplicate of Bug 73803 - Window title, add the numbers of the version to LibreOffice name (I couldn't find it when I was looking for). 
But, in Bug 73803 the request wasn't set as "optional" and the discussion went unfavorably. 
The solution proposed at https://bugs.freedesktop.org/show_bug.cgi?id=73803#c3, is really not acceptable, especially for multiple installations.
Comment 9 Cor Nouws 2014-11-19 14:37:53 UTC
(In reply to Timur from comment #8)
> (In reply to tommy27 from comment #7)
> > it may work with Linux but there are also Windows and MacOS users to think
> > about

They can do the same with any decent text editor.
 
> Right. I would still like this as requested. 

I admit that for many testers it's maybe a bit inconvenient. 
So no objections from me.
And a good candidate for the expert config list, IMO.

> Even that Linux solution is case-by-case, needing manual setup, while I
> suggest that this comes with "default OFF state" in normal and "default ON
> state" in LODEV and parallel installation.

I like that idea.
Comment 10 V Stuart Foote 2014-11-19 14:41:31 UTC
If folks insist on doing this, at least do it right.

Best position would probably be on the main menu bar to the right of the Help menu. Some widget should support it, maybe done as a non-active button label. Imagine text could be a simple parse of the strings held in the Help -> About

Examples of a useful label to optionally show:
(4.2.6.3 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21)
(4.3.4.1 bc356b2f991740509f321d70e4512a6a54c5f243)
(4.4.0.0.alpha2 24f0a5815f581dd9a7f09d30213a379edee6e9ac)
(4.4.0.0.alpha2+ 9229170920ab770624415c4330da57af5b1b5398 @39 2014-11-09)
(4.4.0.0.alpha2+ cc02d84421182c70f1efbb24d1bda749b1f5e422 @46-TDF-dbg 2014-11-18)

Stuart
Comment 11 Heiko Tietze 2014-11-20 08:14:43 UTC
I wouldn't use another menu item for the version number. It's common to have it at the About dialog.
But how's about a 'magic key' (aka autotext) to insert the version number into the current document. Something like bt+F3 for blindtext (might be not available anymore).
Comment 12 Timur 2015-02-06 09:42:51 UTC
Seeing that a proposal for a version number as a menu item had different opinions, I'd like to modify my proposal in order to spur this a little bit. Still, I kindly point out that the version number in the About dialog is sth. different and it stays as it is.

SO, I suggest LO version number be added in the title bar, after "Document name - LO product" as an option that is turned off in a normal installation, available as a command line option, and turned on by default in parallel and DEV versions.

For me, it'd be enough to spot "Document name - LO product - 4.4.0.0.alpha2+  2014-11-18", but other examples of a useful label would be also fine, such as "Document name - LO product - (4.4.0.0.alpha2+ cc02d84421182c70f1efbb24d1bda749b1f5e422 @46-TDF-dbg 2014-11-18)".
Comment 13 m.a.riosv 2015-02-06 09:55:40 UTC
This matter was discussed https://bugs.documentfoundation.org/show_bug.cgi?id=73803 (Window title, add the numbers of the version to LibreOffice name.), resolved as WONTFIX.

I hope more luck this time.
Comment 14 V Stuart Foote 2015-02-06 14:03:28 UTC
(In reply to Timur from comment #8)
> The solution proposed at
> https://bugs.freedesktop.org/show_bug.cgi?id=73803#c3, is really not
> acceptable, especially for multiple installations.

Sorry, still see this as pretty useless clutter--especially now that a functional search capability has been added to ExpertConfig. Such that Regina's suggested workaround from https://bugs.documentfoundation.org/show_bug.cgi?id=73803#c3 is now trivial. Do it once during parallel installation and its always available.

=-ref-=
http://cgit.freedesktop.org/libreoffice/core/commit/?id=1485acc3e86bf6c7e32672c6d36d86e3eb5ddc9e
Comment 15 V Stuart Foote 2015-02-06 15:47:58 UTC
IMHO requested feature is already provided from Expert Config (now with search, so even simpler).

Please give it a try with current builds of master.

Set desired string--version, or other personalization--in the "ooName" Property in the /org.openoffice.Setup/Product stanza.

The resulting string shows anywhere that LibreOffice (or LibreOfficeDev) now shows.  So, appears in all frames (as OS / DE handles it), as the label for File -> Exit button, and labels on the Help menu, or on the Tools -> Options list box, etc.

Beyond the Expert Config search/edit--it might be more convenient for users to provide GUI to set the "ooName" string directly. Perhaps from Tools -> Options -> Personalization

Short of adding that, I would suggest this be Resolved WFM.
Comment 16 m.a.riosv 2015-02-06 22:46:13 UTC
Sure I'm too short for understand the reluctancy about this enhancement, having in account that nobody is obligated to do it.

If it is very hard to implement, fine, that is the answer, otherwise, help a bit to the persons helping is a right way in the project. This is the second request about it.

We are not only one who likes, so please we could allow everyone having their own way on how triage.

Either way I prefer to forget this, seems it's a lost case, and has been time enough spent in it for me.
Comment 17 Adolfo Jayme 2015-02-06 23:15:38 UTC
@mariosv: it’s not about this being easy or difficult to implement. The thing is, UX has evaluated this and deemed it as a non-desirable change of default settings. Developers agree, and you won’t find this in other software as well (does Google Chrome or Firefox have their version numbers there? Nope, because that’s the purpose of having an About dialog). Seems you have a hard time digesting it…