Download it now!
Bug 86514 - Format – Conditional Formatting – Colour Scale... should show more entries in colour dropdowns
Summary: Format – Conditional Formatting – Colour Scale... should show more entries in...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96423 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2014-11-21 07:44 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-04-08 22:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (33.46 KB, image/png)
2014-11-21 07:44 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-21 07:44:37 UTC
Created attachment 109794 [details]
screenshot

When you goto Format > Conditional Formatting > Color Scales, the dialog has color drop downs which only show 3 colors at a time. Most color drop downs show 25 colors at a time.
Comment 1 raal 2014-11-23 14:28:35 UTC
I can not confirm with Version: 4.4.0.0.alpha2+
Build ID: d273a60bfdbf9bb7623bed38667ec0647753157c
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-20_03:05:21
Comment 2 Yousuf Philips (jay) (retired) 2014-11-23 14:37:38 UTC
I had tested it on master on linux.

Version: 4.4.0.0.alpha2+
Build ID: 797db638870f5c6192e72c0b4669b471788e16ea
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-20_03:50:17

And just tested it now on master on Win 7 for the same date and it has 4 entries in the drop down.
Comment 3 Maxim Monastirsky 2014-11-23 15:18:35 UTC
Confirmed with:

Version: 4.5.0.0.alpha0+
Build ID: 37ac70c117a7b8b9ac66b583a793096c3ad87a11
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-11-23_00:38:41

Fedora 21 64-bit KDE desktop.
Comment 4 Maxim Monastirsky 2014-11-23 15:21:12 UTC
This doesn't look like enhancement request.
Comment 5 Matthew Francis 2015-04-09 13:15:31 UTC
This has been the case since the dialog was introduced circa commit b65e98a6a8be0ad7864eb607087d9b85003e5a1e

I think this is in fact an enhancement request. It might not be the most convenient design, but there's nothing about it that stops you doing work - it's just different to the convention elsewhere.

-> Adjusted Summary
-> Severity: enhancement
Comment 6 marcostinez 2015-10-05 11:19:27 UTC
Actually I was wondering why there was a limitation anyway. The optimum would be to be able selecting among the custom colour menu wherever possible.
Comment 7 Yousuf Philips (jay) (retired) 2015-10-11 15:22:45 UTC
The most optimal means would be to change the drop down into the new color selector control, but as the dialog is still .src based, bubli said that isnt possible until the dialog is converted to glade .ui.
Comment 8 Maxim Monastirsky 2015-12-15 11:30:17 UTC
*** Bug 96423 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2017-04-08 22:57:56 UTC
This has been fixed by converting to the new color widget.