Bug 86546 - WRITER UI: More ... options in the new drop-down menus for the Bullets and Numbering toolbar buttons
Summary: WRITER UI: More ... options in the new drop-down menus for the Bullets and Nu...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.5.0 target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-21 23:33 UTC by A (Andy)
Modified: 2014-11-24 15:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2014-11-21 23:33:31 UTC
If you click on the very nice new drop-down menus for the Bullets and Numbering toolbar buttons and select the More Bullets / More Numbering options then this should lead to the corresponding tab in the dialogue box and not the last one selected.

Reproduced with LO 4.4.0.0.beta1.
Comment 1 Adolfo Jayme 2014-11-22 11:03:03 UTC
Thanks for your bug report.
Comment 2 Maxim Monastirsky 2014-11-22 17:08:49 UTC
Hi,

(In reply to A (Andy) from comment #0)
> this should lead to the corresponding tab in the dialogue box
I disagree with this. The drop-down are showing the same items as the corresponding tabs of the dialog, so it doesn't make sense to show those tabs. Instead I propose to default to the "Options" tab for both drop-downs.
Comment 3 Adolfo Jayme 2014-11-22 17:16:51 UTC
(In reply to Maxim Monastirsky from comment #2)
> Instead I propose to default to the "Options" tab for both drop-downs.

Then, the “More Numbering” and “More Bullets” strings are inaccurate.
Comment 4 Maxim Monastirsky 2014-11-22 17:20:11 UTC
(In reply to Adolfo Jayme from comment #3)
> Then, the “More Numbering” and “More Bullets” strings are inaccurate.
They are accurate, because the "Options" tab gives more styles for both numbering and bullets.
Comment 5 Commit Notification 2014-11-23 08:57:54 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb6ced50c11ea71e5655c46e49f17f3b5921f526

fdo#86546 Open the right tab for more bullets and numbering

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Yousuf Philips (jay) (retired) 2014-11-23 10:39:35 UTC
Hi Maxim,

Thanks for the patch. Just a reminder that 4.5 is master now, so please do cherry-pick these new patches for 4.4 if applicable. :D
Comment 8 Adolfo Jayme 2014-11-24 15:50:20 UTC
Jay,

during this phase (until the first RC is released) developers are pushing to 4-4 as well (at their discretion) and no peer review is required. But the bugs aren’t currently receiving commit notifications for that branch because of a bug in the new bugzilla script.