Bug 86605 - CONTEXT MENU: Alignment entry displayed when empty
Summary: CONTEXT MENU: Alignment entry displayed when empty
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2014-11-23 04:26 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-01-11 07:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (25.80 KB, image/png)
2014-11-23 04:26 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-23 04:26:18 UTC
Created attachment 109882 [details]
screenshot

Steps:
1) Open Writer
2) Draw a shape
3) Right-click on shape
4) Select 'Alignment'
5) Notice that the submenu is empty.

This entry should be dimmed or hidden when only 1 object is selected.

Version: 4.4.0.0.alpha2+
Build ID: 797db638870f5c6192e72c0b4669b471788e16ea
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-11-20_03:50:17
Comment 1 A (Andy) 2014-11-23 09:45:12 UTC
Reproducible with LO 4.4.0.0.beta1, Win 8.1.

For me this proposal seems to be consistent, reasonable and good.  This should be context-sensitive (hidden as already in other features done, as far as I know we have dimmed/greyed-out features only in the menus but not in the context menus?). Otherwise, it could irritate the with this feature non-familiar users.
Comment 2 QA Administrators 2015-12-20 16:17:11 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2017-01-03 19:49:43 UTC Comment hidden (obsolete)
Comment 4 Dieter 2018-01-10 20:45:35 UTC
Still valid in Lo 5.4.3

Version: 5.4.3.2 (x64)
Build-ID: 92a7159f7e4af62137622921e809f8546db437e5
CPU-Threads: 4; Betriebssystem:Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 5 QA Administrators 2019-01-11 03:54:06 UTC Comment hidden (obsolete)
Comment 6 Dieter 2019-01-11 07:16:45 UTC
WORKSFORME with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded