Bug 86612 - STATUSBAR: Resized window causes the loss of visibility of zoom functions
Summary: STATUSBAR: Resized window causes the loss of visibility of zoom functions
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: medium enhancement
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords:
: 42894 122703 (view as bug list)
Depends on:
Blocks: Statusbar Impress-UX
  Show dependency treegraph
 
Reported: 2014-11-23 08:23 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-01-14 16:25 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot with red rectangles around the problem fields (133.61 KB, image/png)
2014-11-23 08:23 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-11-23 08:23:46 UTC
Created attachment 109885 [details]
screenshot with red rectangles around the problem fields

Similar to bug 86018, if you resize the impress window under 816 pixels without the selection of any object, the zoom functions begin to disappear. This can easily be rectified by allowing the 2nd and 3rd statusbar fields to reduce in size of about half.
Comment 1 A (Andy) 2014-11-23 08:49:13 UTC
Reproducible with LO 4.4.0.0.beta1, Win 8.1.

If I shrink the IMPRESS window all toolbars / window elements after adapting to this besides the status bar.  In the status bar I have no change, it only gets cropped.  I think, as Jay says, some fields in the status bar could also adapt / shrink as far as it is possible and maybe it could also get a feature like in the toolbars where I get at some degree an arrow on the right to select the other no longer visible features.
Comment 2 Commit Notification 2018-06-28 12:03:35 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d77f8eef165a7c6fd97cc06dcbc4ead55e7b633c

tdf#86612: statusbar: hide some elements if width is not sufficient

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Heiko Tietze 2018-06-29 07:13:56 UTC
@Vasily: Compiled master from today but when I resize the window it still hides the zoom functions. Looking at the code there are mandatory sections now on the SB that are kept visible. Do we have to define the zoom function as mandatory? In other words, what exactly do I have to expect from the patch?
Comment 4 Adolfo Jayme 2018-06-29 07:42:02 UTC
*** Bug 42894 has been marked as a duplicate of this bug. ***
Comment 5 Vasily Melenchuk (CIB) 2018-06-29 15:48:07 UTC
(In reply to Heiko Tietze from comment #3)
> @Vasily: Compiled master from today but when I resize the window it still
> hides the zoom functions. Looking at the code there are mandatory sections
> now on the SB that are kept visible. 

Sry, current patch was including fixes for Draw and Calc statusbars.
Fix for Impress will follow.

> Do we have to define the zoom function as mandatory? 

For all elements mandatory is true by default for backward compatibility. I've just put several mandatory=false for elements which are less important in my mind.

> In other words, what exactly do I have to expect from the patch?

Elements marked as mandatory=false will disappear one by one if window width is not sufficient to fit all status bar elements.
Comment 6 Commit Notification 2018-06-29 22:27:32 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=73a401dac412249c9650b8c13a285c96fff8c523&h=libreoffice-6-1

tdf#86612: statusbar: hide some elements if width is not sufficient

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Heiko Tietze 2018-07-02 06:58:07 UTC
(In reply to Vasily Melenchuk (CIB) from comment #5)
> (In reply to Heiko Tietze from comment #3)
> > @Vasily: Compiled master from today but when I resize the window it still
> > hides the zoom functions. Looking at the code there are mandatory sections
> > now on the SB that are kept visible. 
> 
> Sry, current patch was including fixes for Draw and Calc statusbars.

Got it. Cool feature, works like a charm. Hope you also do it for Writer.
Comment 8 Heiko Tietze 2018-07-02 06:59:13 UTC
PS: Please add this enhancement to the release notes https://wiki.documentfoundation.org/ReleaseNotes/6.1
Comment 9 Samuel Mehrbrodt (CIB) 2018-07-02 07:06:20 UTC
(In reply to Heiko Tietze from comment #7)
> Got it. Cool feature, works like a charm. Hope you also do it for Writer.

Heiko, you could also do this yourself. Just add statusbar:mandatory="false" to the less important elements in the statusbar.xml.

See https://cgit.freedesktop.org/libreoffice/core/diff/sd/uiconfig/sdraw/statusbar/statusbar.xml?id=d77f8eef165a7c6fd97cc06dcbc4ead55e7b633c for an example for Draw.
Comment 10 Commit Notification 2018-07-03 23:56:07 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48e14cbb13ff967e86136b11cf1bebf29e3f54cc

tdf#86612: impress: mark several statusbar elements as optional

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-07-04 05:59:21 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbaa3849618a3aab619e1ed5d0eddaa80a837e88&h=libreoffice-6-1

tdf#86612: impress: mark several statusbar elements as optional

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-07-04 08:47:56 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9a8356d81bba69507861417a73aea98beca2b347

tdf#86612 - Keep zoom visible in Writer

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-07-04 11:17:45 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ea5808780374cb520ec61c8e797f92fb7a6c37cb&h=libreoffice-6-1

tdf#86612 - Keep zoom visible in Writer

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Adolfo Jayme 2019-01-14 16:25:05 UTC
*** Bug 122703 has been marked as a duplicate of this bug. ***