Bug Hunting Session
Bug 86617 - Ruler’s numbers and tick marks have low contrast when using dark KDE themes
Summary: Ruler’s numbers and tick marks have low contrast when using dark KDE themes
Status: RESOLVED DUPLICATE of bug 90214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: KDE UI-Theming Rulers
  Show dependency treegraph
 
Reported: 2014-11-23 10:50 UTC by gnomek
Modified: 2019-01-01 19:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice 5.4 running on KDE 4.14.2 with a dark theme, emphasis on the visible ruler elements (48.76 KB, image/png)
2017-01-06 11:46 UTC, Gökhan Gurbetoğlu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gnomek 2014-11-23 10:50:51 UTC
I use KDE and Libreoffice 4.3.3.2 and there is no way to adjust ruler color.
I have libreoffice-kde package installed (Kubuntu 14.04) so that Libreoffice can use KDE theme. Without it it looks very ugly.
I don't know if it is a matter of this package or Writer itself. Anyway, would be great to have in Writer options → appearance an option to choose user color.
Here is an example how it looks:
http://i.imgur.com/JcuytZs.png

It really makes using ruler almost impossible.

Is there any way user can do something about it?

If not can you accept it as a feature request?
Comment 1 Adolfo Jayme 2014-11-23 18:29:04 UTC
> Is there any way user can do something about it?

Tools > Options > Appearance > Application background, change the color to suit your preference, and then restart the application.
Comment 2 gnomek 2014-11-23 19:04:55 UTC
No. This is not the right solution.
http://i.imgur.com/14hahY0.png
Comment 3 gnomek 2014-11-23 19:07:11 UTC
Sorry. This one is after Writer restart. No desired effect.
http://i.imgur.com/XrCNvpX.png
Comment 4 Adolfo Jayme 2014-11-23 19:11:41 UTC
(Clarifying the issue’s title)
Comment 5 Joel Madero 2015-04-27 05:24:30 UTC
Not limited to KDE - also a regression. See also bug added.
Comment 6 Joel Madero 2015-04-27 05:25:44 UTC
Why is this marked as an EasyHack? EasyHacks require developer input and code pointers. I don't see that at all here.

Setting to needsDevEval (proposed easy hack) to try to get a code pointer.
Comment 7 Heiko Tietze 2015-04-27 09:44:22 UTC
Isn't this a bug since color seems to be set to <clBlack> instead of system setting <clActiveWindowText> (or however it is called here).
Comment 8 Joel Madero 2015-04-30 22:01:33 UTC
Changing severity/priority:

Severity: minor - can slow down professional quality work but will not prevent it;
Importance: low - default for minor issues. The workaround is obviously to just not use a dark theme (I know not perfect...I like dark themes also)

The see also bug has a bibisect to at least identify where the partial regression came from (before the color of the numbers were white when using a dark theme). But from what I can tell the color of the tab stops have always been dark which I agree - makes the ruler very hard to use with a dark theme.


I still suspect that this is an easy hack so I'm going to leave needsDevEval to try to get a code pointer and maybe someone will become interested enough to look into it. Thanks all!
Comment 9 Robinson Tryon (qubit) 2015-12-13 11:23:53 UTC Comment hidden (obsolete)
Comment 10 gnomek 2016-07-13 19:06:48 UTC
> I still suspect that this is an easy hack

Can you please tell me if I can hack it myself by editing any file and how to do it?

I know you have priorities but this problem forces me to use bright themes that make my eyesight worse.
Comment 11 Yousuf Philips (jay) (retired) 2016-11-29 13:39:08 UTC
Would be good to test if this is fixed in KDE after bug 90214 has now been fixed.
Comment 12 Gökhan Gurbetoğlu 2017-01-06 11:46:17 UTC
Created attachment 130197 [details]
LibreOffice 5.4 running on KDE 4.14.2 with a dark theme, emphasis on the visible ruler elements

Checked this with 5.4.0.0.alpha0+ on KDE 4.14.2 and the ruler markers are visible on a dark theme (check the screenshot).
Comment 13 gnomek 2017-02-16 10:50:36 UTC
I can confirm it works in 
http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/2017-02-15_23.38.34/

But can you push it to 5.3.1 please? 

Please don't let all users wait a few months for 5.4 official release. It is important for for dark theme users.

Anyway, thank you very much for this fix.
Comment 14 QA Administrators 2018-06-20 02:49:41 UTC Comment hidden (obsolete)
Comment 15 gnomek 2018-06-28 16:03:35 UTC
It looks ok now:
https://imgur.com/a/btmIbqe

Version: 6.0.5.2
Build ID: 1:6.0.5~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: kde4;
Comment 16 Buovjaga 2019-01-01 19:03:37 UTC
(In reply to gnomek from comment #15)
> It looks ok now:
> https://imgur.com/a/btmIbqe
> 
> Version: 6.0.5.2
> Build ID: 1:6.0.5~rc2-0ubuntu0.16.04.1~lo1
> CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: kde4;

Then let's close.

*** This bug has been marked as a duplicate of bug 90214 ***