Bug 86619 - CONTEXT MENU: Rearrangement of table options
Summary: CONTEXT MENU: Rearrangement of table options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha2
Hardware: Other All
: medium enhancement
Assignee: Yousuf Philips (jay)
QA Contact:
URL:
Whiteboard: target:4.4.0.0.beta3 target:5.0.0
Keywords:
: 86851 89318 (view as bug list)
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2014-11-23 11:48 UTC by Yousuf Philips (jay)
Modified: 2015-05-21 16:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-11-23 11:48:21 UTC
When you are inside a table and you open up the context menu, it has an entry called 'Table...' that leads to the table dialog. Instead table should be a submenu and offer useful options like the submenu entries below it, similar to select table (.uno:SelectTable), delete table (combination of .uno:SelectTable and .uno:DeleteRows), split table (this is available in writer as a context menu entry), AutoFormat, and the last entry should me 'Options', 'More Options', 'Table Options' or 'Properties'.
Comment 1 Yousuf Philips (jay) 2014-11-24 02:12:50 UTC
'Table Boundaries' and 'Number Recognition' should also be moved into this submenu.
Comment 2 Yousuf Philips (jay) 2014-11-30 00:22:33 UTC
'Number Recognition' are set to be removed (bug 86851) and so this bug will remove 'Table Boundaries'.
Comment 3 Yousuf Philips (jay) 2014-12-01 12:27:43 UTC
After going over the OOo stats for the table related entries in Writer's context menu, i'm changing this bug to be an overhaul for all these entries.

Step 1: Submenu Reorganization
The context menu is broken up into submenus for cell, row and column and it would be better that it go according to the table menu which has insert, delete, and select. Also calc's context menu has similar insert and delete options after selecting a cell or row.

Step 2: New Submenus
1) With the removal of the cell submenu, its cell alignment entries should be converted into its own dedicated submenu.
2) With the removal of the row and column submenus, the width... and height... entries can be put into an auofit submenu with entries from Table > Autofit.
3) Cell and table split and merge entries in the menu and submenus can be merged into a submenu.
4) As number format is the second most used table related entry in the context menu, it would be useful to have this as a submenu with the various number formats and a 'more options' entry at the bottom.

Step 3: Entry Removal
1) Table Boundaries - the stats show that ~100% of users set this setting in the Table menu.
2) Number Recognition - as this entry is only available in the context menu, all users set this in the context menu, though its usage is low (its usage is ~50% the usage of table boundaries).
3) Caption - unfortunately their isnt separate stats often its use with tables but i believe it is primarily used with images and charts.

Step 4: Entry Addition
1) AutoFormat - ~20% of users are accessing this in the Table menu, so it would be good to have this at easy reach and ideally label as 'Table Style' or something like that.

Step 5: Section Placement
This section should be located above the character/paragraph section.

Overall the stats show that people primarily open the context menu for the table and number format dialogs and split table. Table manipulation and design are primarily handled in the table toolbar.
Comment 4 Yousuf Philips (jay) 2014-12-02 23:23:44 UTC
*** Bug 86851 has been marked as a duplicate of this bug. ***
Comment 5 Yousuf Philips (jay) 2014-12-09 14:23:40 UTC
First patch is in to handle steps 3 and 5 - https://gerrit.libreoffice.org/13394
Comment 6 Yousuf Philips (jay) 2014-12-09 14:46:31 UTC
For 4.4, only step 3 is being done - https://gerrit.libreoffice.org/#/c/13395/
Comment 7 Commit Notification 2014-12-09 14:54:30 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f463c7bc863744a2bbb4057b64a03d4b73887809&h=libreoffice-4-4

fdo#86619 removal of less used table context menu items (4.4)

It will be available in 4.4.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-12-09 14:55:48 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d0b11411d11050b13b821e847bab86f1247bcea

fdo#86619 removal of less used table context menu items

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Jean-Baptiste Faure 2015-02-14 21:04:26 UTC
*** Bug 89318 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2015-04-27 05:22:53 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06dbd23c2b4d8412fbd1ee10c23f4bcddff667fb

tdf#86619 - Create new table context menu submenus and reorganize entries

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Francisco 2015-04-27 18:20:20 UTC
> 3) Caption - unfortunately their isnt separate stats often
> its use with tables but i believe it is primarily used with images and charts.

Sorry but, I still disagree with this modification. All scientific publication needs table captions, not only images and charts.
Comment 12 Yousuf Philips (jay) 2015-04-27 23:50:50 UTC
(In reply to Francisco from comment #11)
> Sorry but, I still disagree with this modification. All scientific
> publication needs table captions, not only images and charts.

As others have also observed this removal from the context menu (bug 87590, bug 89318), an insert caption button was added to the table toolbar.
Comment 13 Francisco 2015-04-28 00:18:31 UTC
(In reply to Jay Philips from comment #12)
> (In reply to Francisco from comment #11)
> > Sorry but, I still disagree with this modification. All scientific
> > publication needs table captions, not only images and charts.
> 
> As others have also observed this removal from the context menu (bug 87590,
> bug 89318), an insert caption button was added to the table toolbar.

Well, thanks for clarifying, Jay.

Francisco.
Comment 14 Mike §chinagl 2015-05-21 16:19:41 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

Rearrangement of the table context menu. Elaborate on the specific changes! tdf#86619 (Yousuf Philips)