Bug Hunting Session
Bug 86698 - Suggested Functionality: FILE SAVE AS/Export presentation to video
Summary: Suggested Functionality: FILE SAVE AS/Export presentation to video
Status: RESOLVED DUPLICATE of bug 34959
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 96400 (view as bug list)
Depends on:
Blocks: Presentation-Export
  Show dependency treegraph
 
Reported: 2014-11-25 11:26 UTC by Hector A. Recinos
Modified: 2019-03-16 09:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector A. Recinos 2014-11-25 11:26:20 UTC
Suggestion:

File Save As: Avi, WMF, or any video file format.

Presentations have a added value if not all systems support a presentation easily but a video file is accepted easily.
Comment 1 Robinson Tryon (qubit) 2014-12-09 21:31:23 UTC
(In reply to Hector A. Recinos from comment #0)
> File Save As: Avi, WMF, or any video file format.
> 
> Presentations have a added value if not all systems support a presentation
> easily but a video file is accepted easily.

As of LO 4.4.0.0.beta2 on Ubuntu 14.04, there's Flash export support:

  File -> Export -> Macromedia Flash (SWF).

Flash export has a few limitations:
 bug 50792 - FILESAVE: Slideshow transitions and automatic progression lost when exported to Flash
 bug 43526 - Impress functionality request: Exporting a Presentation containing audio narration to FLASH

There's an open bug to support converting a presentation to video, but that bug includes support for a screencast-style recording of the voice of the presenter:
  bug 34959 comment 9

It would be nice to have a simple export to video, with no voiceover support. It would include all of the slides, animations, and embedded audio/video clips.

An open format would be preferred -- perhaps WebM so it could play in a browser (Firefox, Chrome/ium, etc..).

Status -> NEW
Comment 2 raal 2015-12-13 18:25:06 UTC
*** Bug 96400 has been marked as a duplicate of this bug. ***
Comment 3 csongor 2015-12-13 22:23:35 UTC
As I wrote in #94000, the AVI format also should be supported because it would make it easy to play video files on TVs, without a computer.
Comment 4 machineghost 2018-04-09 16:13:01 UTC
Please add support for a standard video format.  It doesn't matter whether it's .avi or .mp4 or what encoding it uses, as long as it's one of the (several different) ones supported by major video players.

Once that export exists it will be trivial to use video applications to convert it to other encodings, so just adding support for one standard export format would be amazing.
Comment 5 Franklin Weng 2019-03-01 02:14:08 UTC
https://ask.libreoffice.org/zh-tw/question/184881/impressru-he-hui-chu-wei-ying-pian-dang/

Same request here.

For implementation I think maybe it is to record the presentation directly to a simple video file (even avi files with motion jpeg).
Comment 6 Heiko Tietze 2019-03-14 09:41:40 UTC
Video encoding sounds like a can of worms to me. You can easily convert the SWF into any other format, even online. My take: WFM.
Comment 7 Cor Nouws 2019-03-16 09:54:47 UTC

*** This bug has been marked as a duplicate of bug 34959 ***