Download it now!
Bug 86726 - FILEOPEN: Spacing and Line spacing increased in DOCX Footnote
Summary: FILEOPEN: Spacing and Line spacing increased in DOCX Footnote
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2014-11-26 08:07 UTC by Ákos
Modified: 2017-06-27 08:52 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Original docx file, created with MSOffice 2013 (14.59 KB, application/msword)
2014-11-26 08:07 UTC, Ákos
Details
Difference between MSOffice, open from doc and open from docx (32.87 KB, application/pdf)
2014-11-26 08:11 UTC, Ákos
Details
Bug evolution LO33-LO35(50) (150.00 KB, image/png)
2015-08-24 10:18 UTC, Ákos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ákos 2014-11-26 08:07:16 UTC
Created attachment 110037 [details]
Original docx file, created with MSOffice 2013

When I import a DOCX file with footnote, in writer the footnote formatting is wrong. Writer insert big spacing between lines, and change the font size from 10pt to 11pt.
I attached the original docx file.
Comment 1 Ákos 2014-11-26 08:11:59 UTC
Created attachment 110038 [details]
Difference between MSOffice, open from doc and open from docx

This file contains the difference between:
Original file in MSOffice 2013
Open original docx file in LibreOffice 4.4.0.0.beta1
Open doc file, saved from original docx file in MSOffice 2013, in LibreOffice 4.4.0.0.beta1
Comment 2 Jacques Guilleron 2014-12-02 17:20:29 UTC
Hi Ákos,

I reproduce with LO 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: fr_FR
& Windows 7 Home Premium.
Can you precise your OS, please?

I set Status to NEW.

Regards,

Jacques
Comment 3 Ákos 2014-12-03 08:17:24 UTC
My OS is Windows 8.1 x64 and I test it on Ubuntu 14.10 x64 with LibreOffice 4.3.3.2 Build ID: 430m0
Comment 4 Ákos 2015-02-02 15:23:37 UTC
The bug still present in LibreOffice 4.4.0.3.
Comment 5 Matthew Francis 2015-04-14 13:41:05 UTC
The excessive spacing for the attached file seems to be inherited from OOo - it's always been that way since LO 3.3.0. However, I haven't been able to reproduce the effect with a new .docx from Mac Office 2.11.

-> Version: Inherited from OOo

The change in footnote font size is a more recent regression - split onto bug 90611
Comment 6 Ákos 2015-06-04 07:28:06 UTC
The bug still present in LibreOffice 5.0.0.0.beta1 32 bit.
Comment 7 Timur 2015-06-05 13:38:12 UTC
(In reply to Matthew Francis from comment #5)
> The excessive spacing for the attached file seems to be inherited from OOo -
> it's always been that way since LO 3.3.0.
> -> Version: Inherited from OOo
There used to be extra line break after each footnote in OO, Bug 39205, which looks like spacing at first, but that was solved long time ago.
If you look further up to 4.1.6, you'll see that line spacing is Single, while from 4.2.0 it becomes Proportional, and spacing is also increased. So, current behavior started from 4.2.0.
What's not clear is why spacing between lines still looks big in LO even if we set spacing to Single and 0.
Comment 8 Ákos 2015-07-28 10:27:43 UTC
The bug still present in LibreOffice 5.0.0.4 32 bit.
Comment 9 Ákos 2015-08-24 10:18:13 UTC
Created attachment 118110 [details]
Bug evolution LO33-LO35(50)

I this screenshot can see the bug evolution:
LibreOffice 3.3.4 - this bug wasn't present, only a + new line character
LibreOffice 3.4.0.1 (this image is corrupt, and I can't test this version: https://downloadarchive.documentfoundation.org/libreoffice/old/)
LibreOffice 3.4.1.3 - The ORIGIN of bug, the new line character still exist
LibreOffice 3.5.7.2-5.0.1.2 - The new line character bug is resolved, but the space still exist.

Another problem is the footnote reference character size. In all version of LibreOffice the footnote reference character is normal, not superscript.
Comment 10 Ákos 2015-08-25 08:08:54 UTC
> LibreOffice 3.4.0.1 (this image is corrupt, and I can't test this version:
> https://downloadarchive.documentfoundation.org/libreoffice/old/)

The archive is OK, only don't contain digital signature...

I test the bug with LibreOffice 3.4.0.1, and I can confirm, that this is the first version, where the bug is present.
Comment 11 Ákos 2015-12-28 16:01:14 UTC
The bug still present in LibreOffice 5.1.0.1 32 bit.
Comment 12 Ákos 2016-06-13 14:39:42 UTC
The bug is resolved.
The first release where is resolved is LibreOffice 5.2.0.0.alpha1.

In any version of LibreOffice 5.1.x.x.x where I test it, is present.
Comment 13 Cor Nouws 2016-06-13 21:46:21 UTC
Hi, thanks for confirming/clarity!
When an issue is resolved without clear code commit, we always set as
WorksForMe.