Bug 86739 - Add option on insert image dialog to set image's anchor type: ToCell or ToPage
Summary: Add option on insert image dialog to set image's anchor type: ToCell or ToPage
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.1.0
Keywords:
: 61680 (view as bug list)
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2014-11-26 12:41 UTC by SriJanani
Modified: 2018-02-09 16:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SriJanani 2014-11-26 12:41:10 UTC Comment hidden (obsolete)
Comment 1 A (Andy) 2014-11-26 22:07:18 UTC Comment hidden (obsolete)
Comment 2 SriJanani 2014-11-27 03:48:03 UTC
Hi Andy,

Due to huge file size attachment did not get attached yesterday. I have uploaded the document in the below link.

https://wiki.documentfoundation.org/File:Noname.ods  

Steps to reproduce: 

1) Open the attachement-> document is created with multiple rows-> If You insert row/column in between any lines the aligement of the others rows/columns changes not static. 

Thank you,

Regards,
SriJanani
Comment 3 SriJanani 2014-12-04 05:54:09 UTC
I would like to share what I have found-> If I anchor the pictures by right clicking on it Anchor to cell and then insert new line or column the aligment does not change. So does that mean Anchoring to cell is not happening by default in Libre office. 

Thank You,

Regards,
SriJanani
Comment 4 raal 2014-12-08 22:12:22 UTC
Enhancement -> anchor to cell as default or allow to change it in options
Comment 5 raal 2015-04-23 15:56:55 UTC
Setting as new -  add option to set image's anchor type: ToCell or ToPage
Comment 6 Timur 2017-06-22 16:35:40 UTC
This was confirmed before defining the resolution. 
On image insert, OO and LO 3.3 had anchor to cell as default. LO 3.4 and on has anchor to page as default. 
Let's ask someone why it was changed and why we should change it back based on single example. 
Other possibility is to have option on insert image dialog to set image's anchor type: ToCell or ToPage, as in previous comment. I support that but we need to change title then. 

PS: There was crash on this file with 6.0+ which was fixed with Bug 108610.
Comment 7 Timur 2017-07-07 07:49:38 UTC
*** Bug 61680 has been marked as a duplicate of this bug. ***
Comment 8 p_kongstad 2017-07-07 16:06:14 UTC
As everything in a spreadsheet is about cells why should pictures not default to cell? This is rather clear to me that is should.
Comment 9 Commit Notification 2018-01-13 10:04:12 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e9bea4dcb6b780a3ef720858bb5dca92b065a39

tdf#86739 Anchor inserted images to cell by default

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Samuel Mehrbrodt (CIB) 2018-02-06 08:23:23 UTC
I'll work on this.
Not that the original bug (inserting rows should move images down) is fixed in current master (bug 98931). In the example document, you just need to change the images to be anchored to cell.
Comment 11 Commit Notification 2018-02-08 15:42:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=38774ce79b4b24628c3a73f387489bf2498363f1

tdf#86739 Option to set image anchor type in image insert dialog

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 p_kongstad 2018-02-09 15:13:26 UTC
Please backport to 6.0 as well.

Thank you.
Comment 13 V Stuart Foote 2018-02-09 15:37:06 UTC
(In reply to p_kongstad from comment #12)
> Please backport to 6.0 as well.
> 

Sorry, but this (and work on bug 98931) is a new feature implemented at 6.1, it is not a good candidate for backport.