Download it now!
Bug 86798 - Writer Document scrolls slowly and does not allow to select text
Summary: Writer Document scrolls slowly and does not allow to select text
Status: RESOLVED DUPLICATE of bug 80659
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
: 104907 105866 (view as bug list)
Depends on:
Blocks: Matters-to-Caolan Writer-Images Scrolling-PageUpDown Selection
  Show dependency treegraph
 
Reported: 2014-11-27 18:31 UTC by Roland
Modified: 2018-02-14 14:55 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
ALLMENDA letter template with background image (104.91 KB, application/vnd.oasis.opendocument.text)
2014-11-27 18:31 UTC, Roland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland 2014-11-27 18:31:29 UTC
Created attachment 110145 [details]
ALLMENDA letter template with background image

Since migration from Ubuntu 12.04 to 14.04, letters based on our template can hardly be used anymore. The problem happens with LibreOffice Writer 4.2.7.2 and has been confirmed also on the actual 4.3 release by @FloEff (when meeting him at our Linuxday in Dornbirn). 

Steps to reproduce:
Open attached document
scroll up and down -> slow reaction
mark up text _> not possible

The template has a background image embedded.
Comment 1 Cor Nouws 2014-11-27 19:08:50 UTC
Hi mEdwards,

I can confirm the sluggish behaviour.
Tested on 4.3.5.1
 
When I add another image to the background of the page, it's some faster. 

Best,
Cor
Comment 2 Cor Nouws 2014-11-27 19:09:39 UTC Comment hidden (obsolete)
Comment 3 Björn Michaelsen 2014-12-12 02:07:12 UTC
Comment on attachment 110145 [details]
ALLMENDA letter template with background image

setting proper mimetype on attachment
Comment 4 Björn Michaelsen 2014-12-12 02:09:31 UTC
Please specify the exact version of which you know it last worked and then mark this as a regression in "keywords".
Comment 5 Roland 2014-12-15 06:51:19 UTC
Marked as regression.  Worked with LibreOffice 3.5.7.2 Build-ID: 350m1(Build:2) = Version in use with Ubuntu 12.04.
Comment 6 Dave Richards 2014-12-31 17:45:16 UTC Comment hidden (obsolete)
Comment 7 Matthew Francis 2015-01-11 10:57:11 UTC
The behaviour seems to have changed as of the below commit.

Adding Cc: to caolanm@redhat.com. Could you possibly take a look at this? Thanks


commit 2e5167528f7566dd9b000e50fc1610b7bf99132a
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Thu Oct 31 14:43:21 2013 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Tue Nov 5 15:24:18 2013 +0000

    Resolves: #i123500# unified Graphic processing to use GraphicPrimitive2D
    
    (cherry picked from commit f5d69b2b8b002ca6905496a9d9065ef76b5641d7)
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:10:52 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2016-09-26 15:03:07 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2017-10-04 14:50:18 UTC
*** Bug 105866 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2017-10-04 14:51:39 UTC
*** Bug 104907 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2018-02-14 14:55:09 UTC

*** This bug has been marked as a duplicate of bug 80659 ***