Download it now!
Bug 86897 - FileOpen: Read Error. Format error discovered in file in sub-document content.xml at 2,215736(row,col).
Summary: FileOpen: Read Error. Format error discovered in file in sub-document content...
Status: RESOLVED DUPLICATE of bug 85496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-01 10:09 UTC by Daniel Naegeli
Modified: 2014-12-01 21:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample part of content.xml, double format tags after "T31" and "T32" (6.62 KB, text/plain)
2014-12-01 10:09 UTC, Daniel Naegeli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Naegeli 2014-12-01 10:09:37 UTC
Created attachment 110290 [details]
Sample part of content.xml, double format tags after "T31" and "T32"

For the third time in two months I had this Format Error in different ODS-charts. 
In the attached sample (part) double format tags are found after "T31" in col 3884 and again after "T32" in col 4169. 
It is possible to repair the chart but annojing and needs quite some knowledge about XML format and a good editor.
In LO and OO Forums several help requests concerning this error can be found.
I hope this bug can be fixed soon. Perhaps also a general tool to repair XML format errors would be helpful. If it exists already it should be mentioned in the help of LO.
Comment 1 Michael Stahl (allotropia) 2014-12-01 12:30:14 UTC
Daniel, do you happen to have a step-by-step recipe to reproduce the bug?

the relevant of the attachment:

<style:style style:name="T31" style:family="text">
  <style:text-properties fo:font-style="normal" style:font-style-asian="normal" xstyle:font-style-comple="normal" fo:font-style="italic" style:font-style-asian="italic" style:font-style-complex="italic" fo:color="#008000"/>
</style:style>

duplicate attributes fo:font-style style:font-style-asian style:font-style-complex

has anybody fixed something like this recently?
Comment 2 Daniel Naegeli 2014-12-01 13:38:51 UTC
(In reply to Michael Stahl from comment #1)
> Daniel, do you happen to have a step-by-step recipe to reproduce the bug?
Not at the moment. I was not able to locate the cell in the original chart. But I will have a look at the other chart where that happened.
I could imagine it has something to do with formatting one of several words in a cell as "italic". 
 
> has anybody fixed something like this recently?
I fixed it just by deleting the duplicate attributes as you cited them. 
That was the advice I got in the LO-forum. 
See also: http://en.libreofficeforum.org/node/2961#comment-21092
Comment 3 Michael Stahl (allotropia) 2014-12-01 21:00:22 UTC
ah it's a spreadsheet, not a chart document, so duplicate of bug 85496 which i found today, and that one has a reproducer...

*** This bug has been marked as a duplicate of bug 85496 ***