Bug 86957 - "Window -> Freeze" produces an .xlsx file incompatible with MSO 2010 "Freeze Panes"
Summary: "Window -> Freeze" produces an .xlsx file incompatible with MSO 2010 "Freeze ...
Status: RESOLVED DUPLICATE of bug 101042
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-03 05:08 UTC by Kevin Suo
Modified: 2016-12-03 16:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
xlsx file produced in step 2 (4.50 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-12-03 05:09 UTC, Kevin Suo
Details
xlsx file produced in step 4 (7.65 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-12-03 05:09 UTC, Kevin Suo
Details
step 2 screenshot (98.61 KB, image/png)
2014-12-03 05:17 UTC, Kevin Suo
Details
step 4 screenshot (108.52 KB, image/png)
2014-12-03 05:18 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-12-03 05:08:28 UTC
When I apply "Window -> Freeze" then save a spreadsheet to .xlsx, the file saved is incompatible with MSO 2010.

Steps to reproduce:

1. New Calc, click B2, then apply "Window -> Freeze";

2. Save as .xlsx;

3. Open the .xlsx file with MSO 2010.
--> "View -> Freeze Pane" is grayed out. (i.e., LibreOffice produced an xlsx file in which "Freeze Pane" feature is incompatible with MSO).

4. Based on step 3 (within MSO 2010), type "1" in A1 (or do any other editing), then save the file and reopen.
--> The sheet tabs are missing. (i.e., we do not see the sheet tabs "sheet1, sheet2...")
(This must be caused by the "Freeze Pane" issue, as when you do not do "Window -> Freeze" in step 1, the .xlsx file in step 4 will be OK).


Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: zh_CN

Version: 4.3.5.1
Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889

Win 7 X64 & Ubuntu 14.10 x64.
Comment 1 Kevin Suo 2014-12-03 05:09:11 UTC
Created attachment 110386 [details]
xlsx file produced in step 2
Comment 2 Kevin Suo 2014-12-03 05:09:46 UTC
Created attachment 110387 [details]
xlsx file produced in step 4
Comment 3 Kevin Suo 2014-12-03 05:17:27 UTC
Created attachment 110388 [details]
step 2 screenshot
Comment 4 Kevin Suo 2014-12-03 05:18:39 UTC
Created attachment 110389 [details]
step 4 screenshot
Comment 5 Kevin Suo 2014-12-03 05:19:55 UTC
The related code seems to be in:
sc/source/filter/excel/xeview.cxx
Comment 6 raal 2014-12-03 12:49:57 UTC
I can not confirm with Version: 4.3.6.0.0+
Build ID: 9e57326acebde972df22ea4368b5ce4822d51330
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time: 2014-11-27_12:21:59
excel2010

I can not confirm with Version: 4.4.0.0.beta1+
Build ID: 0bd7e1cfed956b0cb2dcdfac9d382e044440d119
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2014-11-27_05:31:01
excel2010
Comment 7 raal 2014-12-04 07:45:06 UTC
I looked at your screenshot and I can confirm screenshot step 2. Setting as NEW

I can not reproduce step 4.

I can confirm also with LO 4.3.4.1, win7 -> changing version
Comment 8 Kevin Suo 2014-12-04 08:36:01 UTC
(In reply to raal from comment #7)
Thanks for confirming.

For step 4:
* Are you doing the changes in MSO 2010?
* Are reopening the file with MSO 2010?
* My MSO 2010 version: 14.0.7015.1000 32bit.
Comment 9 raal 2014-12-05 08:43:57 UTC
(In reply to Kevin Suo from comment #8)
> (In reply to raal from comment #7)
> Thanks for confirming.
> 
> For step 4:
> * Are you doing the changes in MSO 2010?
> * Are reopening the file with MSO 2010?
> * My MSO 2010 version: 14.0.7015.1000 32bit.

Yes, mso 2010
Comment 10 QA Administrators 2015-12-20 16:20:48 UTC Comment hidden (obsolete)
Comment 11 Kevin Suo 2015-12-21 01:54:14 UTC
(In reply to QA Administrators from comment #10)
Still reproducable with:
Version: 5.1.0.1 (x64)
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 4; Ver: Windows 6.19; Render: GL; 

Locale: zh-CN (zh_CN)
Comment 12 Kevin Suo 2016-07-29 06:42:23 UTC
Seems fixed in
Version: 5.3.0.0.alpha0+
Build ID: 9dc3356f1499a2b90078be86ca7470eb2e96aba8
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-07-21_23:52:45
Locale: zh-CN (zh_CN); Calc: group

Mark as WORKSFORME.
Comment 13 Kevin Suo 2016-12-03 16:05:11 UTC
Tested and I confirm this one is really a duplicate of bug 101042.

*** This bug has been marked as a duplicate of bug 101042 ***