Download it now!
Bug 87021 - About screen should show build date
Summary: About screen should show build date
Status: RESOLVED DUPLICATE of bug 79438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-05 07:04 UTC by thangalin
Modified: 2014-12-07 15:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thangalin 2014-12-05 07:04:22 UTC
Feature request. To replicate:

1. Start LibreOffice
2. Click Help >> About

Expected Results

Version information includes build date (and timestamp).

Actual Results

No timestamp.
Comment 1 Adolfo Jayme 2014-12-05 17:45:54 UTC
Thank you for your bug report.
Comment 2 brij 2014-12-06 09:47:11 UTC
Please provide some info how to obtain build date and timestamp.
Thanks!
Comment 3 V Stuart Foote 2014-12-07 07:01:20 UTC
For nightly builds, the build date and source buildbot details are already included in the development builds.

Official release builds do not need the release date, as they are stamped with the SHA1 build ID of the final commit that is included in the build. That ID can directly reference the cgit log database for build details.  All OS versions of a build will have the same build ID. And, for the 4.4.0 build onward, the localization language selected for the install is also now included on the help about panel, as this was judged useful for problem reporting.

The date a build is completed can vary by OS, but will have the same build ID.

If needed, a review of the date stamp of any of the LibreOffice executables on the local system should suffice.

But, for users desiring project build dates in context, an archive for released builds is maintained by the project--dates of each build are available there: http://downloadarchive.documentfoundation.org/libreoffice/old/

And the project Wiki offers the release plan
https://wiki.documentfoundation.org/ReleasePlan
Comment 4 V Stuart Foote 2014-12-07 15:52:40 UTC
Clearly a duplicate, but still suggesting won't fix status.

*** This bug has been marked as a duplicate of bug 79438 ***