Download it now!
Bug 87053 - Heading 2 numbers lost after DOC format
Summary: Heading 2 numbers lost after DOC format
Status: RESOLVED DUPLICATE of bug 106541
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Bullet-Number-Lists DOC-Styles
  Show dependency treegraph
 
Reported: 2014-12-06 16:43 UTC by David A. Wheeler
Modified: 2020-04-24 06:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A .doc file with automatically-numbered headings (36.50 KB, application/msword)
2014-12-06 16:43 UTC, David A. Wheeler
Details
A .doc file compared MSO LO (93.82 KB, image/png)
2020-02-07 10:10 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David A. Wheeler 2014-12-06 16:43:44 UTC
Created attachment 110512 [details]
A .doc file with automatically-numbered headings

"Heading 2" automatic numbering is mysteriously lost on DOC import.

Actions:
1. Load the attached .doc file into LibreOffice with automatically-generated heading numbers.  These created by linking the paragraph types "Heading 1" and "Heading 2" to a list type named "Headings" ( per http://shaunakelly.com/word/numbering/numbering20072010.html ).

Expected behavior:
The first "Heading 2", with text "More stuff", should be preceded with the numbering "1.1" (as it is in Microsoft Word).

Actual behavior:
The "Heading 2" automatically-generated numbering is completely missing; only the text appears.

This may be related to #87052.  I tried working around the bug in #87052 involving DOCX import by creating a DOC file, and ended up with this probably-different bug.  Which means I'm stuck!
Comment 1 Buovjaga 2014-12-16 14:17:12 UTC
Confirmed.

Lowering severity a bit per https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46
Comment 2 Buovjaga 2015-01-12 15:54:05 UTC
Confirmed in Word viewer that More Stuff really has 1.1 preceding it.

This bug is already present in 3.3.0.

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 A (Andy) 2015-12-27 20:27:25 UTC
Reproducible with LO 5.1.0.1, Win 8.1
Comment 4 QA Administrators 2017-01-03 19:54:40 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-12-19 14:06:34 UTC
still repro in 

Version: 6.3.0.0.alpha0+
Build ID: 2b9739b9b009de93efa4f24995469c3bb9d82261
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-18_23:09:56
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 6 Timur 2019-09-06 10:14:12 UTC Comment hidden (me-too)
Comment 7 Timur 2020-02-07 10:10:50 UTC
Created attachment 157727 [details]
A .doc file compared MSO LO

Repro LO 7.0+.
Comment 8 Justin L 2020-04-23 19:14:10 UTC
The Heading * styles in LO have special meaning, so it is dangerous to play with them. Check out tools - Chapter numbering and you will see that level 2 is empty. After fixing this I was able to round-trip it in LO.

So the question now is, why is Word accepting the numbering, but LO isn't?

repro 7.0+
Comment 9 Justin L 2020-04-23 19:20:45 UTC
This looks like the same thing as bug 106541
Comment 10 Buovjaga 2020-04-24 06:41:28 UTC
Ok, let's dupe to the newer report this time.

*** This bug has been marked as a duplicate of bug 106541 ***