Download it now!
Bug 87075 - 4.4.0.beta2 on OSX "installs" a bunch of unwanted dictionaries
Summary: 4.4.0.beta2 on OSX "installs" a bunch of unwanted dictionaries
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:5.4.0
Keywords:
: 92226 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-07 17:07 UTC by Martin Srebotnjak
Modified: 2017-03-19 19:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Wrongly? installed lang packs (62.23 KB, image/png)
2014-12-07 18:00 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2014-12-07 17:07:06 UTC
The beta2 of 4.4.0 seems to localize a bunch of dictionaries which appear in the list of installed extensions just as "dict-af", "dict-an", "dict-ar", "dict-be", ..., "dict-zu".
Since I installed only basic dmg (which until now installed only English dictionaries) plus the Slovenian lang-pack for OS X (both packages are 64-bit), I am not sure whether these dictionaries are coming from the basic build of from the Slovenian package, but they should not have been installed anyway.
Comment 1 Martin Srebotnjak 2014-12-07 18:00:29 UTC
Created attachment 110538 [details]
Wrongly? installed lang packs
Comment 2 retired 2014-12-08 10:16:53 UTC
Not sure if those are really needed. I ran into this as well and wondered what is going on. Maybe a dev can elaborate? Confirmed and NEW.

10.10.1 and LO Version: 4.5.0.0.alpha0+
Build ID: a26222f5af55e8ffe9784dd411485d3c5c72e983
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2014-12-07_00:14:47
Locale: de_
Comment 3 Martin Srebotnjak 2015-07-28 13:14:25 UTC
I looked into those folders and they are actually empty. So only English dictionary gets installed with basic DMG, but all this folders get created. I am changing the title of the bug accordingly, moving verb installs into parenthesis.

Since they are empty the Extension Manager shows those dictionaries on the list, but since there are no description files it doesn't show their (localized) names/description, just the name of the folder (i.e. "dict-sl", "dict-ar").

If I am to speculate, I think this is done during the main dmg installation so that when a lang-pack is installed, it can then install (actually just copy) the actual dictionary files into that created folder (maybe the lang-pack has no proper rights to create new folders in the installed app so this is done in advance?).

If this is not necessary, these should all be removed from the main dmg.

Maybe one could test that theory by installing the English dmg, manually deleting all these empty folders and then installing a lang-pack to see if additional dictionaries get into it without problem or not.
Comment 4 Martin Srebotnjak 2015-08-11 06:37:15 UTC
I will close this as the other bug I filed for same thing describes it more thoroughly.
https://bugs.documentfoundation.org/show_bug.cgi?id=92226

*** This bug has been marked as a duplicate of bug 92226 ***
Comment 5 Commit Notification 2017-03-19 19:08:45 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fbcdca2becb4eee0825697efffba14b5796ade6d

tdf#87075: Filter out unused directories from FILELISTs

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Stephan Bergmann 2017-03-19 19:12:38 UTC
*** Bug 92226 has been marked as a duplicate of this bug. ***