Bug Hunting Session
Bug 87083 - 4.4.0.beta2 inline help images horizontally stretched
Summary: 4.4.0.beta2 inline help images horizontally stretched
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords:
: 87633 89017 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-07 22:33 UTC by Martin Srebotnjak
Modified: 2015-02-17 11:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The inline help images on main help page (198.57 KB, image/png)
2014-12-07 22:33 UTC, Martin Srebotnjak
Details
stretched icons (31.44 KB, image/png)
2015-02-01 18:23 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2014-12-07 22:33:32 UTC
Created attachment 110547 [details]
The inline help images on main help page

On 4.4.0.b2 with Slovenian help pack the help inline images (icons) seem to be horizontally stretched.
Comment 1 Adolfo Jayme 2014-12-09 02:15:33 UTC
@Caolán: is helpcontent affected by this commit at all?:
http://cgit.freedesktop.org/libreoffice/core/diff/vcl/source/window/builder.cxx?id=eaa89db886ba49472e22d77cea957a08c1113cd0
Comment 2 Caolán McNamara 2014-12-18 14:23:16 UTC
no
Comment 3 Adolfo Jayme 2014-12-24 05:47:42 UTC
*** Bug 87633 has been marked as a duplicate of this bug. ***
Comment 4 Alex Thurgood 2015-02-01 18:22:01 UTC
Confirming also on Linux 440 production release, FR locale
Comment 5 Alex Thurgood 2015-02-01 18:23:38 UTC
Created attachment 113031 [details]
stretched icons
Comment 6 Alex Thurgood 2015-02-01 18:26:42 UTC
*** Bug 89017 has been marked as a duplicate of this bug. ***
Comment 7 Caolán McNamara 2015-02-09 12:44:43 UTC
I think this is the same problem as bug 83073
Comment 8 Commit Notification 2015-02-10 16:29:09 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=233da237ad4b593c945903c3b32185a540025516

Resolves: tdf#87083 images in help html stuck at default placeholder size

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Caolán McNamara 2015-02-10 16:40:26 UTC
spacing between images and text is still a little screwy so there's something up with that still.
Comment 10 Commit Notification 2015-02-11 16:01:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=64fe9d34c6bae221309a037fc1ca399076a53de9&h=libreoffice-4-4

Resolves: tdf#87083 images in help html stuck at default placeholder size

It will be available in 4.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Jean-Baptiste Faure 2015-02-11 20:29:09 UTC
Thank you very much. Verified fixed in LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64

Best regards. JBF