Download it now!
Bug 87117 - Writer: to resize images proportional now with AltGr+mouse?
Summary: Writer: to resize images proportional now with AltGr+mouse?
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-08 20:07 UTC by Joachim Wiedorn
Modified: 2019-11-03 15:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Wiedorn 2014-12-08 20:07:18 UTC
When I want to resize a image/picture/graphic in writer I used Shift+mouse at one corner of the object.

But since 4.3.4.1 the use have changed: you must use AltGr+mouse. Why? Not understandable! Not communicated!? 

Can I configure the old behaviour? Shift is much better than using AltGr!
Comment 1 Joel Madero 2014-12-09 01:28:32 UTC
Hey Joachim -

This is really just a user preference issue not a bug. The behavior was indeed changed, things change all the time, and every user has a different desire/expectation/etc....

Closing as NOTABUG. 


As for if it's configurable, please ask on the user mailing list or on IRC at #libreoffice.
Comment 2 Adolfo Jayme 2014-12-09 04:23:40 UTC
@Joel: I don’t think we ever specified a change to AltGr, and if it changed in a bugfix (i.e., minor) release (such as 4.3.4), then IT IS a bug.
The modifier key should be Shift according to https://wiki.documentfoundation.org/ReleaseNotes/4.3#Proportion_image_scaling.

Take a little time to read and triage individual bugs…
Comment 3 Joel Madero 2014-12-09 04:44:26 UTC
Well if it's confirmed - then NEW is appropriate not UNCONFIRMED.

There's only so much QA can do . . . I read every bug, I can't spend an hour investigating each one. Thanks for the polite comment though
Comment 4 Joachim Wiedorn 2014-12-09 18:20:06 UTC
Now I have found, that some other things have changed, too. And one of them is the moving of the middle point of a side of the object: since 4.3.4.1 with this
point resizing of the object will retain the aspect ratio. This could be seen as a solution, but:

I think it would be fair to publish such important changes in the right way. Or have I overlooked it somewhere?
Comment 5 Joachim Wiedorn 2014-12-09 18:31:44 UTC
Finally I understand the link of Adolfo Jayme:
https://wiki.documentfoundation.org/ReleaseNotes/4.3#Proportion_image_scaling

The intension is not to use "Shift" anymore if you want resize with proportional scaling. That is a good idea! But please do not change such things as bugfix of a minor release.

Details about these changes can be found in
https://bugs.freedesktop.org/show_bug.cgi?id=71669
Comment 6 QA Administrators 2015-12-20 16:20:14 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:51:07 UTC Comment hidden (obsolete)
Comment 8 eisa01 2019-11-03 15:15:29 UTC
If I read this correctly, 4.3 changed the behavior to scale proportionally by default. With the shift-key you can scale unproportionally

So closing as not a bug