Bug 87120 - SIDEBAR: Paragraph Property panel Line Spacing dropdown--no keyboard selection possible (a11y)
Summary: SIDEBAR: Paragraph Property panel Line Spacing dropdown--no keyboard selectio...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords: accessibility, bibisected, bisected, regression
Depends on:
Blocks: Sidebar-Accessibility Sidebar-Properties-Paragraph
  Show dependency treegraph
 
Reported: 2014-12-08 21:23 UTC by V Stuart Foote
Modified: 2016-10-24 17:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2014-12-08 21:23:15 UTC
On Windows 7 sp1 64-bit, and Linux 64-bit (Fedora 20) with current builds of master, 4.4.0beta2+, beta1+ and 4.4.0 alpha1+

Have a keyboard navigation and a11y issue with the Sidebar Properties Tray in the Paragraph panel.

No selection can be made with cursor/enter key from the drop down list opened with the Line Spacing button.

This functions correctly with the 4.3 branch.

Bibisect results
It was OK through:
Version: 4.4.0.0.alpha1+
Build ID: d9473f25380c627966b4406cc4cdfaafcf44bc37
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-03_04:24:26

but goes bad by
Version: 4.4.0.0.alpha1+
Build ID: 3c58f0768049718fae3d47d5ebfa6c7485ad52b1
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-05_06:43:51

So, http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=d9473f25380c627966b4406cc4cdfaafcf44bc37..3c58f0768049718fae3d47d5ebfa6c7485ad52b1

Kind of looks like http://cgit.freedesktop.org/libreoffice/core/commit/?id=b59b183ce3b84bec6722110ee80d6158b6a60377 caused the regression.
Comment 1 V Stuart Foote 2014-12-09 13:50:23 UTC
Also affecting the Line Spacing split button on the Formatting toolbar. No keyboard movement there either.
Comment 2 Joel Madero 2015-01-05 17:18:39 UTC
Adding bibisected to whiteboard as bisected keyword is a subset of bibisected whiteboard.

Thanks!
Comment 3 Robinson Tryon (qubit) 2015-12-10 03:37:51 UTC
Migrating Whiteboard tags to Keywords: (a11y -> accessibility)
Comment 4 Commit Notification 2016-04-05 19:27:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd46727b99d4bb5135451aa7e5e1bdb197373843

Resolves; tdf#87120 no keyboard navigation inside floating windows

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 V Stuart Foote 2016-04-07 03:31:48 UTC
On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.0.alpha0+
Build ID: 157469896ef56720f33676222b95e81c04ab5c72
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-06_20:10:15
Locale: en-US (en_US)

Verified fixed, thanks!
Comment 6 Maxim Monastirsky 2016-10-19 08:16:06 UTC
*** Bug 76002 has been marked as a duplicate of this bug. ***