Bug 87151 - EDITING: Format of fields in tables is lost, when system input language isn't ignored
Summary: EDITING: Format of fields in tables is lost, when system input language isn't...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2014-12-09 12:01 UTC by Robert Großkopf
Modified: 2016-01-30 19:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

Testdatabase for formatted table - format will be deleted, when changing language settings of LO (4.58 KB, application/vnd.oasis.opendocument.base)
2014-12-09 12:01 UTC, Robert Großkopf
Wrong language in format of table (27.68 KB, image/png)
2014-12-16 18:05 UTC, Robert Großkopf

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-12-09 12:01:40 UTC
Created attachment 110622 [details]
Testdatabase for formatted table - format will be deleted, when changing language settings of LO

Open the database.
Open the table.
It contains a field for currency and another field vor Voltage, which shows "Volt".

Now close the database and set Tools → Options → Language Settings → Languages → Enhance language support → Ignore system input language to "No" (False/deselect), close LO and the reopen the database. The format of the table is gone.
Same when changing the language of the User-Interface.

Seem the language-settings would destroy all format-settings in the table.
Comment 1 Robert Großkopf 2014-12-09 19:30:14 UTC
Have tested it a little bit more:
If you change the langugae under Tools you have to do change something in the database for saving new. Only opening and closing the database wouldnt rewrite the internal content.xml. For example only open the table and change the width of a column. Then you could save base. If you reopen it in most cases the format of the field (€ and Volt) will be lost.

I have had a look at the language for the format of the table. When I had a first look it has been "de" (which couldn't be chosen). When I changed the the language-settings it changed to "Standard (Deutschland)".

Why is there a field for languages? Don't know if there is somebody, who need this field. So there could be added something like "none". Could be this solves the problem here.
Comment 2 Alex Thurgood 2014-12-15 13:50:10 UTC
Can't confirm with regard to 
Tools → Options → Language Settings → Languages → Enhance language support → Ignore system input language to "No" (False/deselec

as this is not selected by default in my master build OSX 10.10.1

Build ID: c70d907c6bac7720338207355e41724ba1e97781
Locale: fr_
Comment 3 Alex Thurgood 2014-12-15 13:54:12 UTC
Can also not confirm after changing application language to English(USA).
Comment 4 Alex Thurgood 2014-12-15 13:56:10 UTC
Also resized a field in table, saved, shut down LO, reopened file, no difference in formatting.

Either fixed in master or Linux specific ?
Comment 5 Joel Madero 2014-12-16 16:26:55 UTC
Setting to WFM per Alex's comment.

@Robert - if you could test 4.4 beta2 and and see if you still see the issue. If so can you provide information about your distro? If you can still reproduce on 4.4 beta2 or later, please set the bug to UNCONFIRMED and provide additional steps on what we expect to see. Thanks!
Comment 6 Robert Großkopf 2014-12-16 18:05:18 UTC
Created attachment 110917 [details]
Wrong language in format of table

Ok, seems to be a little bit tricky.
I couldn't reproduce the bug whith the document I have uploaded.
I couldn't send a screenshot in English, because the language would change, what I want to show:
I open a table for editing, where the format was lost during changing language.
There I see "Sprache → de".
This language couldn't be chosen by the formatting of the field. Could be it is the language from my system ("de" - OpenSUSE 12.3, 64bit rpm Linux, KDE).

This bug has been reported from another person: http://www.libreoffice-forum.de/viewtopic.php?f=10&t=14297 (only in German ...) So I tried to reproduce and get the same error. Will test how to reproduce this for everybody.
Comment 7 Robert Großkopf 2014-12-16 18:42:08 UTC
Have tested a little bit more whith opening and closing and switching input language. Then I created new tables in the database of the first attachment. Couldn't reproduce with the new, but suddenly the old table has lost the format.

I got the same error with the first database I created here. Format loss there for two tables. All the same behavior, when I open the format of the table there appears the language "de", which couldn't be chosen in the listfield for languages, but is shown there, as you could see by the attached screenshot.

Have got this error with LO, OpenSUSE 12.3 64bit rpm Linux, KDE. Couldn't test LO 4.4 or 4.5, because of another bug with my configuration and KDE (black menu).

I will set this back to unconfirmed and hope I will get a better way to reproduce.

Could be it is as tricky as the behavior of the language-settings in Bug67615.
Comment 8 Stephan 2014-12-19 08:33:12 UTC

could confirm the bug. There seems to be a general problem with localisation settings in Base (this bug and the textvarchar bug with "0" instead of "@" in the format field), and in other applications (Writer, Calc), see these bug reports:


This bug here does not occur always, but when a base file is saved, closed and reopened several times, the chance is about 100% that all local formats of currency and date fields are forgotten.

Perhaps the bug will never be reproducable on operating systems based on the english language. 

But it is yet important, just look at the Manifesto of The Document Foundation:
"Manifesto  Our values
We commit ourselves:
to support the preservation of mother tongues by encouraging all peoples to translate, document, support, and promote our office productivity tools in their mother tongue"

Comment 9 Stephan 2014-12-19 09:17:28 UTC
Oh, and my OS is Windows 7 64bit German Version using LO
Comment 10 Robert Großkopf 2014-12-21 20:40:51 UTC
I set this to NEW. See https://bugs.freedesktop.org/show_bug.cgi?id=87151#c8
Comment 11 Alex Thurgood 2015-01-03 17:41:09 UTC
Adding self to CC if not already on
Comment 12 James B. Byrne 2015-01-04 23:48:42 UTC
It happens in LO English (GB) LO when Database has language English (USA). OSX-10.9.5.
Comment 13 QA Administrators 2016-01-17 20:04:40 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)


2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword

Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 14 Robert Großkopf 2016-01-30 19:24:38 UTC
Don't know if the bug has gone. Couldn't reproduce it, but it has been a coincidence to reproduce.

Have tested with LO and OpenSUSE 42.1 64bit rpm Linux.

I will set this bug to RESOLVED and WORKSFORME. Feel free to reopen if you could confirm the buggy behavior with LO 5.1.*