Bug 87224 - Character borders shown separately for Western and Far East runs
Summary: Character borders shown separately for Western and Far East runs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 96462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-11 07:19 UTC by Junichi Matsukawa
Modified: 2016-09-23 13:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
disconnected boders (14.41 KB, image/png)
2014-12-11 07:19 UTC, Junichi Matsukawa
Details
underline_split (7.46 KB, image/png)
2014-12-11 09:55 UTC, Junichi Matsukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Junichi Matsukawa 2014-12-11 07:19:37 UTC
Created attachment 110719 [details]
disconnected boders

LBO4.4.0.0.beta1 windows7(32)
writer

1.use japanese font:TakaoEXminchou etc.
2.write A mix of full-width and half-width text.
3.focus the text.
4.right mouse crick.
5.”Characters”
6.”Borders”
7.border has been disconnected.
Comment 1 Urmas 2014-12-11 08:23:33 UTC
Confirming.
Comment 2 Junichi Matsukawa 2014-12-11 09:52:45 UTC
LibreOffice Forum of Japan as well as case studies was noted.

The underline split.
On a shape you can see clearly.
Comment 3 Junichi Matsukawa 2014-12-11 09:55:08 UTC
Created attachment 110727 [details]
underline_split

The underline split.
Comment 4 tommy27 2016-04-16 07:27:40 UTC Comment hidden (obsolete)
Comment 5 Mark Hung 2016-07-10 16:35:14 UTC
*** Bug 96462 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2016-08-24 00:08:08 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5fab973d0af95c433c5f6a9492014f7db642489

tdf#87224 Merge character borders across different scripts.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.