Download it now!
Bug 87241 - freeze when creating a report with Java 1.8
Summary: freeze when creating a report with Java 1.8
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.5.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsJRE8
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-11 16:16 UTC by Roman Kuznetsov
Modified: 2015-04-28 10:52 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (9.24 KB, text/plain)
2014-12-11 16:16 UTC, Roman Kuznetsov
Details
file database (13.74 KB, application/vnd.oasis.opendocument.database)
2014-12-11 16:16 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2014-12-11 16:16:19 UTC
Created attachment 110742 [details]
backtrace

when trying to create a report in the attached database, LO is freeze
Comment 1 Roman Kuznetsov 2014-12-11 16:16:58 UTC
Created attachment 110743 [details]
file database
Comment 2 Roman Kuznetsov 2014-12-11 16:18:16 UTC
LO 4.3.5.1, Windows 7 x86_64, JRE 1.8.025
Comment 3 Julien Nabet 2014-12-11 20:43:30 UTC
kompilainenn: do you use Java 32 bits or 64 bits?
Indeed, LO is built on 32 bits only on Windows so it needs Java 32 bits.
Comment 4 Joel Madero 2014-12-12 05:17:12 UTC
Marking as NEEDINFO as Julien has asked a question that needs addressed

@Kompilainenn - if you are running 64 bit JRE, please install 32 bit and try again. If you still experience the problem mark as UNCONFIRMED and provide the additional info requested.

Thanks for taking the time to report.
Comment 5 Roman Kuznetsov 2014-12-12 05:20:37 UTC
(In reply to Julien Nabet from comment #3)
> kompilainenn: do you use Java 32 bits or 64 bits?
> Indeed, LO is built on 32 bits only on Windows so it needs Java 32 bits.

I'm usw 32bit JRE. With 64bit JRE LO Base not work
Comment 6 tommy27 2014-12-13 07:58:12 UTC
hi, what about Bug 87051 - LibO freezes when closing Base 

are those 2 different issues or are you describing the same problem twice?
Comment 7 Roman Kuznetsov 2014-12-13 09:30:10 UTC
(In reply to tommy27 from comment #6)
> hi, what about Bug 87051 - LibO freezes when closing Base 
> 
> are those 2 different issues or are you describing the same problem twice?

this is 2 different issues, bug 87051 - freeze AFTER close Base. But maybe the developers say that this is one problem
Comment 8 Roman Kuznetsov 2014-12-13 09:32:05 UTC
It seems that the problem in version JRE 1.8. JRE 1.7 version did not seem to cause friezes
Comment 9 Jacques Guilleron 2014-12-26 15:35:51 UTC
Hi kompilainenn,

I don't reproduce using LO 4.3.5.1
Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889
& Windows 7 Home Premium
JRE 1.7.0_65

Regards,
  
Jacques
Comment 10 Alex Thurgood 2015-01-03 17:40:39 UTC
Adding self to CC if not already on
Comment 11 Julien Nabet 2015-01-14 21:49:12 UTC
Thank you kompilainenn for your feedback.
I put it back to UNCONFIRMED since I don't have more questions.
Comment 12 Robinson Tryon (qubit) 2015-01-14 22:11:36 UTC
(In reply to Jacques Guilleron from comment #9)
> Hi kompilainenn,
> 
> I don't reproduce using LO 4.3.5.1
> Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889
> & Windows 7 Home Premium
> JRE 1.7.0_65

Hi Jacques: Looks like OP indicated that it only happens w/JRE v1.8. Could you please test again and see if you can confirm the bug? Thanks!
Comment 13 Buovjaga 2015-01-17 13:12:48 UTC
Opened attachment 110743 [details].
Reports - Create report in design view.
Freeze.

Jre 1.8.0_25

Win 7 Pro 64-bit, LibO Version: 4.4.0.2
Build ID: a3603970151a6ae2596acd62b70112f4d376b99

Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
Comment 14 Jacques Guilleron 2015-01-17 18:28:21 UTC
With: 
LO 4.3.5.1 Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889 and jre 1.8.0_25, 
I first got a crash, once launched wizard to create the report, by selecting the first field. The next times, the report could be created without issue.
LO 4.3.5.2 Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5 works fine.
These versions work fine also with jre 1.7.0_71.

LO 4.4.0.1 Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f Locale : fr_FR
LO 4.4.0.2 Build ID: a3603970151a6ae2596acd62b70112f4d376b990 Locale : fr_FR
LO 4.5.0.0.alpha0+ Build ID: a405184aa972ca375f04205fd22f83d54952648d
TinderBox: Win-x86@42, Branch:master, Time: 2015-01-13_06:42:22 Locale: fr_FR
with jre 1.8.0_25 or jre 1.7.0_71
& Windows 7 Home Premium,
application freeze.

Jacques
Comment 15 Lionel Elie Mamane 2015-02-04 06:30:23 UTC
(In reply to Jacques Guilleron from comment #14)
> With: 
> LO 4.3.5.1 Build ID: 8fd0451cc08e6a5310bed8b7ad1c46b93c1c6889 and jre
> 1.8.0_25, 
> I first got a crash, once launched wizard to create the report, by selecting
> the first field. The next times, the report could be created without issue.
> LO 4.3.5.2 Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5 works fine.
> These versions work fine also with jre 1.7.0_71.

So, essentially you DO NOT reproduce this bug, which is supposed to happen in 4.3.5.1

> LO 4.4.0.1 Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f Locale : fr_FR
> LO 4.4.0.2 Build ID: a3603970151a6ae2596acd62b70112f4d376b990 Locale : fr_FR
> LO 4.5.0.0.alpha0+ Build ID: a405184aa972ca375f04205fd22f83d54952648d
> TinderBox: Win-x86@42, Branch:master, Time: 2015-01-13_06:42:22 Locale: fr_FR
> with jre 1.8.0_25 or jre 1.7.0_71
> & Windows 7 Home Premium,
> application freeze.

This smells like you reproduced bug 88824, not this one.
Comment 16 Lionel Elie Mamane 2015-02-04 06:36:02 UTC
(In reply to Beluga from comment #13)
> Opened attachment 110743 [details].
> Reports - Create report in design view.
> Freeze.
> 
> Jre 1.8.0_25
> 
> Win 7 Pro 64-bit, LibO Version: 4.4.0.2
> Build ID: a3603970151a6ae2596acd62b70112f4d376b99
> 
> Version: 4.5.0.0.alpha0+
> Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
> TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46

Since you only tested with 4.4 and 4.5alpha, it is not clear that you reproduced this bug, which is supposed to happen with 4.3, as opposed to bug 88824 which appeared in 4.4.

I'm thus putting back this bug in UNCONFIRMED, until we have one of:

 * independent reproduction with 4.3
OR
 * reproduction with a version where bug 88824 is fixed, that is a
   "pre 4.4.1 beta/rc/snapshot" of today (or later) or
   a 4.5.0.alpha0 snapshot of today or later.
OR
 * some other reproduction that makes it clear that it is not reproducing
   bug 88824
Comment 17 mc 2015-02-10 21:08:18 UTC
I have same problem:
On my existent db files, now open Reports is impossible or create a new.

In two Pc: Windows 7 64bit , LO 4.4.0.3 , Java 1.8.0_31
Comment 18 Lionel Elie Mamane 2015-02-11 05:48:27 UTC
(In reply to mc from comment #17)
> I have same problem:
> On my existent db files, now open Reports is impossible or create a new.

> In two Pc: Windows 7 64bit , LO 4.4.0.3 , Java 1.8.0_31

You are maybe experiencing bug 88824, which is fixed for 4.4.1
Comment 19 Buovjaga 2015-02-11 18:50:18 UTC
I can't reproduce the crash with jre 1.8 on Ubuntu with 4.3.5.2 or 4.3.6.2.
Comment 20 Alex Thurgood 2015-04-05 09:13:41 UTC
@kompilainenn: do you still have this problem with LO 442 ?
Comment 21 Roman Kuznetsov 2015-04-05 12:52:36 UTC
(In reply to Alex Thurgood from comment #20)
> @kompilainenn: do you still have this problem with LO 442 ?

in LO 4.4.2.1 Base does not freeze when creating a report with JRE 1.8u40 on Windows 7 HB x86-64
Comment 22 Julien Nabet 2015-04-05 13:09:08 UTC
Thank you kompilainenn for your feedback, let's put this one to WFM.