Bug 87314 - Copying gallery clipart from Draw to Writer leaves broken image
Summary: Copying gallery clipart from Draw to Writer leaves broken image
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsOSX
Keywords:
Depends on:
Blocks: Gallery Paste
  Show dependency treegraph
 
Reported: 2014-12-15 03:53 UTC by Matthew Francis
Modified: 2017-08-26 13:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the issue (750.36 KB, image/png)
2014-12-15 03:54 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-12-15 03:53:43 UTC
Reproduced on OSX 10.10 / Libreoffice 4.3.4.1 and 4.4.0.0beta1

Steps to reproduce:
1. Insert a piece of gallery clipart into a Draw document
2. Copy the clipart
3. Paste into a Writer document

Expected results:
The clipart is pasted

Actual results:
A broken image is pasted
Comment 1 Matthew Francis 2014-12-15 03:54:17 UTC
Created attachment 110840 [details]
Screenshot of the issue
Comment 2 Buovjaga 2014-12-16 12:53:55 UTC
Unable to reproduce.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: 170616e9f2d30c1302bbb5a7a4b588bc05cd5cc9
TinderBox: Win-x86@39, Branch:master, Time: 2014-12-12_01:58:46

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: f92183833fa569006602ac7e93c906d2094e0d4d
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-14_00:21:45
Comment 3 Joel Madero 2014-12-16 15:58:20 UTC
Not reproducible:

Ubuntu 14.04 x64
LibreOffice 4.4 beta 2

Maybe OSX specific?
Comment 4 Robinson Tryon (qubit) 2014-12-30 05:30:26 UTC
(In reply to Joel Madero from comment #3)
> 
> Maybe OSX specific?

cc'ing Steve to help repro.
Comment 5 retired 2015-01-01 12:31:00 UTC
Confirmed 4.4RC1
OSX 10.10.1
NEW
OSX only

I see what the screenshot shows when copy pasting a clipart from Draw to Writer.
Comment 6 QA Administrators 2016-01-17 20:05:07 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-03-06 14:35:59 UTC Comment hidden (obsolete)
Comment 8 eisa01 2017-08-26 13:25:27 UTC
Inserting clipart from Media->Gallery in Draw and copying into Writer works for me

Version: 5.4.0.3
Mac OS X 10.12.6