Bug 87385 - Another problem updating chart data ranges.
Summary: Another problem updating chart data ranges.
Status: RESOLVED DUPLICATE of bug 83606
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-16 21:44 UTC by klsu
Modified: 2014-12-18 17:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description klsu 2014-12-16 21:44:53 UTC
Copy and rename a sheet with a chart having:
   Range for Name $[other sheetname].$[H/M/R/W]$57
   Categories $[other sheetname].$C$4:$C$56
   and 4 Ranges for Y-Values $[other sheetname].$[H/M/R/W]$4:$[H/M/R/W]$56
   On the copied sheet manually change $56 in Categories and Ranges for Values to $36 (i.e., show data for 33 years instead of 53). When the changes are made, the chart appears updated, however, when a cell elsewhere on the sheet is selected to force exiting the chart edit mode, the old/unchanged chart is shown, including in page preview, even though the chart is shown correctly again in the edit mode, until the spreadsheet is manually saved.

Also related to or duplicate of 83606.
Comment 1 raal 2014-12-17 10:24:24 UTC
Hello klsu,
see the comment 13 of bug 83606
Confirmed that d5a0926c2359a4f8bd48cbea5a9c034b87d6aeeb is the commit that fixed this

Could you test with LO dev 4.4 ->  http://dev-builds.libreoffice.org/daily/  ?

If bug doesn't occurs with daily builds, set as duplicate, if not let us know. Thank you
Comment 2 raal 2014-12-17 17:45:25 UTC
Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you

I can not confirm with simple chart in Version: 4.4.0.0.beta2+
Build ID: e1de94244c1b0419c1c3415c02381e8b7a87abe0
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2014-12-14_11:45:23
Comment 3 klsu 2014-12-18 15:34:01 UTC
Sorry, it took some learning to get Lubuntu running in a VM. I have confirmed that the problem has been fixed in LODev 4.4, so this one can be closed. Now when I find a problem I can check to see if it has been fixed in the latest Beta...
Comment 4 raal 2014-12-18 17:21:45 UTC
Thank you for confirming. Also on windows you can use dev version alongside with standard version of LO.

*** This bug has been marked as a duplicate of bug 83606 ***