Bug Hunting Session
Bug 87404 - UI: mouse over comments field in cell left a line of artifact behind
Summary: UI: mouse over comments field in cell left a line of artifact behind
Status: RESOLVED DUPLICATE of bug 73287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-17 09:35 UTC by VincentYu
Modified: 2016-02-18 05:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Artifact test case (799.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-29 03:39 UTC, rebelxt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VincentYu 2014-12-17 09:35:01 UTC
Move mouse to the red dot at upper right corner of cell to show the comment, after moving mouse away the comment box disappears(which is correct) but it leaves a black line from the upper edge behind. Multiple comment fields left multiple artifact lines behind.
Comment 1 raal 2014-12-17 19:10:45 UTC
I can not confirm with LO 4.3.4,win7. Could you test with newer version?
Comment 2 Robinson Tryon (qubit) 2014-12-27 06:07:20 UTC
(In reply to raal from comment #1)
> I can not confirm with LO 4.3.4,win7. Could you test with newer version?

Status -> NEEDINFO

(please change status back to UNCONFIRMED after you reply to raal. Thanks!)
Comment 3 rebelxt 2015-01-29 03:39:18 UTC
Created attachment 112902 [details]
Artifact test case

I can see artifacts left over after rolling the mouse over two comments in the attached test case. Redrawing the window with the mouse wheel or the scroll bar will eliminate the artifacts. I see the artifacts on three different versions of LO:

Linux Mint 13
Version: 4.5.0.0.alpha0+
Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-12_00:54:59

Linux Mint 13
Version 3.5.7.2

Linux Mint 17
Version: 4.3.5.2
Build ID: 430m0(Build:2)
Comment 4 Robinson Tryon (qubit) 2015-01-30 16:34:31 UTC
TESTING with LO 4.4.0.3 + Ubuntu 14.04

REPRO Steps:
- Open test case (attachment 112902 [details]) in LibreOffice
> Move mouse to the red dot at upper right corner of cell to show the comment,
> after moving mouse away the comment box disappears(which is correct) but it
> leaves a black line from the upper edge behind. 

CONFIRMED

> Multiple comment fields left
> multiple artifact lines behind.

CONFIRMED

> Redrawing the window with the mouse wheel or the
> scroll bar will eliminate the artifacts.

Yes, but (at least for me) I have to scroll until the artifacts are completely off the screen to force them to redraw; just moving the page slightly up or down is not enough to redraw everything.

Status -> NEW
Comment 5 VincentYu 2015-05-26 01:35:56 UTC
Just upgraded to 4.3.7.
The same problem but this time I can't even adjust the size of the comment window(It worked in 4.2.6).
Comment 6 rebelxt 2015-07-30 13:37:41 UTC
Since the Show Comment/Hide Comment sequence does not leave artifact lines behind, can whatever is done there be replicated in this situation?

The current daily build (Version: 5.1.0.0.alpha1+ Build ID: 74d4168f8830f7bbec6b784c3fb774296d9adafa TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-22_06:14:00) installed in Linux Mint 17.2 is leaving even more obvious artifacts. They do leave the user with the sense that this software is rather unprofessional.
Comment 7 rebelxt 2016-02-18 05:14:17 UTC
I believe this to be a duplicate of bug 73287. I don't know if I am allowed to mark it as such.
Comment 8 VincentYu 2016-02-18 05:26:27 UTC
(In reply to rebelxt from comment #7)
> I believe this to be a duplicate of bug 73287. I don't know if I am allowed
> to mark it as such.

Just upgraded to 4.4.7 and able to reproduce it again.
Yes, I think it's a duplicate.

*** This bug has been marked as a duplicate of bug 73287 ***