Bug 87448 - drawingML import: cloud shape is mis-rendered
Summary: drawingML import: cloud shape is mis-rendered
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-18 14:16 UTC by Miklos Vajna
Modified: 2016-12-08 22:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Reproducer document (16.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-12-18 14:16 UTC, Miklos Vajna
Details
Screenshot showing the problem. (111.77 KB, image/png)
2014-12-18 14:22 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2014-12-18 14:16:59 UTC
Created attachment 110989 [details]
Reproducer document

The attached document has visible rendering problems in case the x and y scaling of the shape do not equal. The problem is specific to how <a:arcTo> commands are handled in the shape path. It's .doc version is not affected, as only the drawingML import produces ARCANGLETO commands in the document model.
Comment 1 Miklos Vajna 2014-12-18 14:22:56 UTC
Created attachment 110990 [details]
Screenshot showing the problem.
Comment 2 Commit Notification 2014-12-18 18:28:57 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20f8006e21943b08f1f152e4a0359c9ebe4786f2

fdo#87448 EnhancedCustomShape2d: fix handling of scaled ARCANGLETO commands

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.