Download it now!
Bug 87491 - Track Changes: After clicking "Next Track Change" the "Insert Track Change Comment" is not enabled for some changes
Summary: Track Changes: After clicking "Next Track Change" the "Insert Track Change Co...
Status: RESOLVED DUPLICATE of bug 79197
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2014-12-19 12:42 UTC by riesslibo
Modified: 2019-01-31 13:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example odt with tracked changes for comment function behavior for the first change (11.33 KB, application/vnd.oasis.opendocument.text)
2014-12-19 12:42 UTC, riesslibo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description riesslibo 2014-12-19 12:42:48 UTC
Created attachment 111043 [details]
example odt with tracked changes for comment function behavior for the first change

Problem statement for Win7/64 LibO 4.4.0.0. Beta2 (RC2)!: 

If you open a document with tracked changes and the icon bar for changes is displayed and you click on the right arrow to find the first change (cursor is after opening at the beginning of the document) the first change is marked. In the icon bar the icons for accepting or refusing this change is enabled, not the icon for the comment. When you click on the right arrow icon again (the next change is marked) and on the left arrow to move to the first change again, now the comment icon is enabled and you can use it. The same disable/enable behaviour is seen in the menu Edit-Changes not only in the icon bar. 

Expectet behaviour: Even with the first move to the first change I want to give a comment on it, so even with the first step to the first change the comment icon / menu entry is enabled.

Steps to reproduce the behaviour:
1. Open Writer and enable the change tracking icon bar.
2. Open the document I will provide here, it is with a few tracked changes 
3. After opening the Cursor is located at the first position in the first page
4. click icon next change, the next changed line is selected 
5. in the icon bar the accept and refuse icons are enabled, the comment icon not.

6. click next change, click last change
7. the comment icon is enabled.
Comment 1 A (Andy) 2014-12-21 08:36:42 UTC
Reproducible with LO 4.4.0.0.beta1 (Win 8.1).
Comment 2 Cor Nouws 2015-10-07 10:18:18 UTC Comment hidden (obsolete)
Comment 3 Cor Nouws 2015-10-07 11:08:41 UTC Comment hidden (no-value)
Comment 4 riesslibo 2015-10-20 10:31:42 UTC
Hi Cor,

thanks for caring about this bug.

But sorry, this is not the same for me, a comment to the text is not the same as the comment to a tracked change, as it is handled in the commit/discharge dialog with accepting changes. If it should be the same, two icons makes no sense and the fact, that after hitting next and hitting back it works, seems to me that these are two different kind of comments.

So, for me it doesn't work also with 5.0.2.2
I don't know if I'm alloud to reopen the bug, but if, i would reopen it ;-)

Cu, Lothar
Comment 5 Cor Nouws 2015-12-27 20:27:48 UTC
(In reply to riesslibo from comment #4)

> So, for me it doesn't work also with 5.0.2.2
> I don't know if I'm alloud to reopen the bug, but if, i would reopen it ;-)

Sure you are.
But let me reopen it for you: indeed it is not OK.
Any idea if it worked fine in a previous version? (Hmm I think the Track Changes tool bar wasn't available that long ago.)
Comment 6 Cor Nouws 2015-12-27 20:28:04 UTC
confirmed
Comment 7 QA Administrators 2017-01-03 19:57:35 UTC Comment hidden (obsolete)
Comment 8 Timur 2017-04-18 07:35:42 UTC
Another example attachment 106821 [details] from Bug 84300. Confirmed with libo-master~2017-04-16_23.49.21_LibreOfficeDev_5.4.0.0.alpha0_Win_x86. Looks like bug from the implementation in 4.0.
Comment 9 QA Administrators 2018-04-19 02:34:33 UTC Comment hidden (obsolete)
Comment 10 László Németh 2019-01-31 13:41:07 UTC

*** This bug has been marked as a duplicate of bug 79197 ***